Login page - Input fields refresh/empties after 5 seconds

Infos:

  • Used Zammad version: 5.1.1-1651218076.e3861908.centos7
  • Used Zammad installation type: yum
  • Operating system: CentOS 7
  • Browser + version:
    • Firefox 91.3.0esr
    • Chrome 90.0.4430.85
    • Edge 101.0.1210.32

Expected behavior:

  • Login page won’t reload some of it’s DOM-Elements each 5 seconds

Actual behavior:

  • The DOM element #app reloads its child elements every 5 seconds, this results in clearing the username and password fields
  • if you are fast enough in typing, you can login

login-refresh

Steps to reproduce the behavior:

  • Unknown

Background

We currently have several instances of Zammad running (as a VM).
One of these instances was unfortunately neglected, so it is still running on version 2.6.0.
I wanted to upgrade it to the latest version, but since it is a production instance, I wanted to test it with a clone first.
The update was done step by step, 2.6.0 → 3.0.0 → 3.6.0 → 4.0.0 → 5.1.1 considering all dependencies of Elasticsearch and Postgresql.
I have checked each version for functionality and the behavior only occurs since the update to 5.1.1.

The same problem existed here before, but was closed due to non-response → 2.9.x login issue after upgrade · Issue #2523 · zammad/zammad · GitHub

Answer to the asked questions in the old issue:

  • Something in the productive.log: unfortunately no
    • Also nothing in zammad.access.log, zammad.error.log, nginx.log
  • Are there change on files (e.q. CSS):
    • in /opt/zammad/ no
    • becaus it is a clone, I hat to change the hostname to -klon, and also changed it in the /etc/nginx/nginx.conf and /etc/nginx/conf.d/zammad.conf
    • created an self-signed certificate for the new hostname
  • zammad run rake db:migrate was execuded
  • zammad run rake searchindex:rebuild was execuded
  • zammad run rake assets:precompile was execuded

Sorry but that smells like a browser or addon specific issue.
I’ve never seen a Zammad instance do such a sketchy thing.

Using either incognito mode or safe mode of your browser could solve the issue.
If it does, disable your addons one by one to find the evil boii.

proof

Thank you for your reply. This is exactly the kind of answer I was afraid of.

Currently I have 3 systems with the same version in use and only with this one system this problem occurs.

I have tested it with the 3 browsers mentioned above and now also again to be completely sure with a freshly installed Firefox without add-ons in SafeMode, but still the same problem.


Just now also once again performed a full update:

  • kernel.x86_64 3.10.0-1160.66.1.el7
  • zammad.x86_64 5.1.1-1655712708.d1d67c32.centos7
  • elasticsearch.x86_64 7.17.4-1
  • nginx.x86_64 1.20.1-9.el7
  • postgresql96.x86_64 9.6.24-1PGDG.rhel7

Using the Firefox debugger I was able to trace the problem back to the “websocket” → “message” operation (see gif)
As soon as you jump into the function the input disappears.

login-refresh-2

Unfortunately I see nothing in the logs on the server nor in the console of the browser.

I hope this further information helps. If there is anything else you want me to test, let me know.

(This problem is so strange - I’m still hoping that this is just happening because it’s a cloned system with subsequently changed names).

I honestly have no tips I can share on how to overcome this issue.
If this is a vanilla installation then the behavior indeed is strange.

Websocket messages shouldn’t cause a silent reload, usually this would happen (without silence) on a configuration change. However, this will trigger a modal. Possibly you have old cached files in your browser which may be your issue.

In case you wonder what modal I’m talking about, the maintenance section “Message” would show such a modal Maintenance — Zammad documentation