Locale issue on Login page (only)

  • Used Zammad version: 5.x.x
  • Used Zammad installation type: package
  • Operating system: Debian 10, Windows, iOS
  • Browser + version: Chrome, Safari, Edge, Firefox

Expected behavior:

  • Load Login Page in language version corresponding to browser’s settings

Actual behavior:

  • It looks like zammad in some cases doesn’t recoginze browser’s locale settings and loads login page in English. After you login language settings work properly.

Steps to reproduce the behavior:

  • I’ve tried few webbrowsers on different systems. First on Windows, Firefox and Edge work fine in both normal and private mode. Chrome works fine only in normal mode, when I switch to incognito login page is always in English.
    On iOS, Safari, Chrome, Firefox all open login page in English and after successful login everything is properly translated.

You may be mixing things - just to be sure, if you test those things you may want to ensure to use a fresh user. Theoretically the permission (agent or customer) shouldn’t matter on this matter.

The reason is that Zammad uses the language the user may have configured or changed.
To be close to able to reproduce this one would need these information:

  • the whole set of languages the browser in question requests (not just the first, but also the alternatives)
  • the language that’s displayed

I’m not sure if I understand correctly, sorry. What do you mean by saying “the whole set of languages the browser in question requests (not just the first, but also the alternatives)”?

When I open webpage on PC using chrome Login page displays Polish language, when I open the same page on ios/android devices the same page is displayed in English. After user is logged in, Zammad is displayed correctly on all devices (in my case Polish).

A web browser does have “preffered” language settings.
This means it can tell a website which language it prefers (and also can provide an order of language alternatives to use if the first preffered one is not available).

I want that list.

This page can help you with that, be aware that it’s overloaded with ads.

We’d need that for both browsers.

Hi, thanks for the answer. Here it comes.

and login page from the same device

So I did have a look on my phone and tried to reproduce this.
I’ve checked Safari and Chrome.

Chrome doesn’t care about my language preferences at all (even though it’s the browser actually “allowing you” to adjust the preffered language. It still returns de-de no matter if I add only pl-pl or not. Safari does not care at all which is why I can’t reproduce this in a reliable way that’d help.

On my desktop switching browser preffered languages and Zammads detection on unauthenticated sites works as expected on Zammad 5.0.3.

I’m sorry, I’m aware that this does not really help you, still I wanted to give feedback on my learnings.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.