Ldap sync has stopped working


  • Used Zammad version: 5.0.3
  • Used Zammad installation type: package
  • Operating system: ubuntu
  • Browser + version: firefox 96

Expected behavior:

Actual behavior:

ldap sync has stopped working. following message is on channel. but is not fixed, looking for neustaten all the time and says wait a moment. On production and scheduler log is no error about this. Can someone help ?

An error occurred: Interrupted by scheduler restart. Please restart manually or wait till next execution time.

Steps to reproduce the behavior:

  • zammad worker-1 restarted also the server itself, nevertheless the error persists.

I, [2022-01-31T15:39:20.399439 #1543-174940] INFO – : Started GET “/api/v1/integration/ldap/job_start?=1643642026186" for at 2022-01-31 15:39:20 +0000
I, [2022-01-31T15:39:20.403256 #1543-174940] INFO – : Processing by Integration::LdapController#job_start_index as JSON
I, [2022-01-31T15:39:20.403290 #1543-174940] INFO – : Parameters: {"
I, [2022-01-31T15:39:20.416089 #1543-174940] INFO – : Completed 200 OK in 13ms (Views: 0.2ms | ActiveRecord: 4.0ms | Allocations: 8531)

I could first fix as follows, I hope that is permanently fixed.

zammad run rails c
job = ImportJob.create(name: 'Import::Ldap', payload: Setting.get('ldap_config'))

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.