LDAP Connection Error: Name or service not known

  • Used Zammad version: 6.2
  • Used Zammad installation type: pAKAGE
  • Operating system: UBUNTU 20.04
  • Browser + version: MICROSOFT EDGE

Expected behavior:

  • while connecting with LDAP Integration. it should connect with AD/LDAP Server and Sync cridentials

Actual behavior:

  • While Connecting giving errors : Can’t connect to (**** LDAP Host Name****) on port ‘636’, getaddrinfo: Name or service not known. And doesn’t continue after that

Steps to reproduce the behavior:

  • Go to Zammad Setting… Select Integration . Select LSAP . Click on new source . Fill the required data and returns error. It happens in both cases where LDAP is on , And where LDAP is off from Zammad side. Also checked other solutions didn’t work.

Your keyboard seems to be broken…

The error you receive indicates that the hostname cannot be resolved.

I have created the host name on LDAP Server with Admin Permission. Still the same

I don’t understand what you’re trying to say.
How in the world is Zammad, a different server / system, supposed to know about a hostname “you set up on a different machine” ?

I like to know about the issue All Zammad Integration of LDAP asks for Host Name and account username. Nothing more. Or is there proper Guide for that

Even my server is hosted on same server

I don’t get the issue and therefore I cannot help, @SaifNeon. I’m sorry.

Hi,
I am having the same / similiar issue.
I have had Zammad running for close to 12 months and had no issue.

I have just noticed that zammad is not syncing with my LDAP server (AD).

I am seeing the below error message come up.
I have logged in via ssh and the i can ping the name without any problem and i am connected to the ldap service on other systems without any other problem.

UBUNTU 22.04
Zammad version 6.1.0-1699563276.d63911c3.jammy

Its like I connect LDAP Server with Zammad from Zammad features it shows me above mentioned error

It tells you it can’t connect. Look for the cause of that. This is not a Zammad error persé.

I meant I used same credentials before for Connecting others tools with LDAP Server. It worked normally. Its showing onyl for Zammad that xxxxxxxxx Site Cannect on port “636” Name or service unknown

You don’t seem to be understand that the error message is not speaking about invalid credentials but the connection not working. You have to find the cause for that.

What is the best way to test this connection from the Zammad host?
I am able to connect from another machine to the ldap server and browse the directory without any issues.
I can ping the ldap machine from the Zammad host
I can telnet to port 389 and recieve a connected message

I have the same error.
I am running 6.2.0-1707903324.09151676.bullseye

Editing the LDAP config and removing the traling slash at the end of the hostname helped. I have no f****ing clue where that came from. :smiley: