Knowledge Base configuration

Infos:

  • Used Zammad version: 3.0
  • Used Zammad installation source: (source, package, …) apt
  • Operating system: Ubuntu 16.04 LTS
  • Browser + version: Chrome

Hello,

i would like to use the knowledge Base. It is possible to configure in admin settings, but i can´t open the knowledge base. I think i dont understand the custom url configuration.
My Helpdisk is ticket.domain.de with nginx. If i understand custom url, i enter /help und get the webserver configuration. I have been integrated this 2 lines into /etc/nginx/sites-available/zammad.conf. But i can´t open the knowledge base with ticket.domain.de/help, browser run´s into timeout. What is the correct custom url configuration?

Thank you

Please remove your 2 extra lines from nginx-configuration you added (whatever they are…) as by default, the rails route is /help - so frankly: You’ll already be able to access /help.

If that doesn’t help, please provide:

  • access/error log of nginx from the moment you’re trying to call the troublesome URL
  • zammad-production log of the exact same moment
  • configuration file of nginx
  • configuration of your Knowledge Base (especially the custom URL is interesting here)

Otherwise it’s impossible to help you. :slight_smile:

thank you for your answer.

  • error log of nginx shows nothing
  • production.log of zammad shows:

Started GET “/help” for 95.90.214.243 at 2019-06-10 14:54:38 +0200
I, [2019-06-10T14:54:38.743767 #7511-47092960140220] INFO – : Processing by KnowledgeBase::Public::CategoriesController#forward_root as HTML
I, [2019-06-10T14:54:38.754140 #7511-47092960140220] INFO – : Redirected to http://ticket.DOMAIN.de/help/en-us
I, [2019-06-10T14:54:38.756032 #7511-47092960140220] INFO – : Completed 302 Found in 12ms (ActiveRecord: 3.5ms)

configuration of zammad nginx:

this is the nginx config for zammad

upstream zammad {
server localhost:3000;
}

upstream zammad-websocket {
server localhost:6042;
}

server {
listen 80;

# replace 'localhost' with your fqdn if you want to use zammad from remote
server_name ticket.DOMAIN.de;

root /opt/zammad/public;

access_log /var/log/nginx/zammad.access.log;
error_log  /var/log/nginx/zammad.error.log;

client_max_body_size 50M;

location ~ ^/(assets/|robots.txt|humans.txt|favicon.ico) {
    expires max;
}

location /ws {
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "Upgrade";
    proxy_set_header CLIENT_IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_read_timeout 86400;
    proxy_pass http://zammad-websocket;
}

location / {
    proxy_set_header Host $http_host;
    proxy_set_header CLIENT_IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_read_timeout 180;
    proxy_pass http://zammad;

    gzip on;
    gzip_types text/plain text/xml text/css image/svg+xml application/javascript application/x-javascript application/json application/xml;
    gzip_proxied any;
}

listen 443 ssl; # managed by Certbot

ssl_certificate /etc/letsencrypt/live/ticket.DOMAIN.de/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/ticket.DOMAIN.de/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

custom url:
acutally nothing, before your post /help

Replace the above against this:

upstream zammad {
server 127.0.0.1:3000;
}

upstream zammad-websocket {
server 127.0.0.1:6042;
}

Or ensure that localhost always resolves to 127.0.0.1

The error should be gone from what I can see, as production log says it’s shipping the help page. If not maybe it’s nginx or something working BEFORE your server