Integrate email account into Zammad


Zammad 5.3.1
Debian 11.5
Exchange Server 2016

I am trying unsuccessfully to integrate the e-mail account (helpdesk) into Zammad.

Channels → Email
IMAP SSL port: 993
IMAP is enabled, IMAP service running on Exchange

Message: no connection to host

I can ping the host via Debian.

Does anyone of you have an idea what it could be? I’m grateful for any help.

Many greetings

This is an english speaking community. Please translate your article or remove it.

Hi @Referat17, can you provide the tech support info as per the template I posted below? I can’t tell from your provided information whether you’ve installed from package or are using docker-compose.

From your provided info I don’t see any reason why IMAP wouldn’t work, especially since you can ping from the Zammad server to the Exchange server.

My first recommendation would be to review the Zammad knowledge base articles for the Email channel, and make sure there’s nothing obviously wrong:

As a sanity check you could try using a command line Linux email program like Mutt on the Debian server, and confirm that it’s actually possible to connect using IMAP.


  • Used Zammad version:
  • Used Zammad installation type: (source, package, docker-compose, …)
  • Operating system:
  • Browser + version:

Expected behavior:

Actual behavior:

Steps to reproduce the behavior:

Hello spats,

okay, a bit more structured.


  • Used Zammad version: 5.3.1
  • Used Zammad installation type: (source, package, docker-compose, …) package
  • Operating system: Debian 11.5 + Exchange 2016
  • Browser + version: Firefox

Expected behavior:

Email address as contact and reply address in Zammad +
Integrate Exchange contacts into Zammad.

Actual behavior:

It doesn’t work Host not found.

Steps to reproduce the behavior:

I am trying to connect the address via IMAP via Channels → Email:
Host not found

Thanks for pointing out the admin docs. I tried the same. Unfortunately in vain.


The error message is not host not found but “server unavailable”.
That’s a very Exchange specific error message.

Usually caused by either your IMAP service not running or not being configured.
IMAP is not available by default in Exchange and thus has to be activated manually.

Also you may want to fix your notification sender adress as mentioned here:

You’re mixing two topics:

  • email channel (and its fetching)
  • email notification channel

The Services are running.

Do you have a send connector setup for Zammad, or your Zammad IP in a current send connector?

@ Sal

I don´t know. How do I get out of there?

It has been a while since on premise exchange. By default it will not allow Zammad to send emails, you will need to create a Send Connector to allow it. If you are not sure what a send connector is, then you best do some reading on that before making any changes.

Hopefully that helps.

1 Like


thx :slightly_smiling_face:

From the Exchange side or from the Zammad side?

If this is a production environment, then proceed with caution. You can easily break exchange. Please make sure you read up on how they work before making any changes.

This is in Exchange 2016 ECP, you’ll find Mail Flow options. Under there, Send Connectors. You need these in order for exchange to work, and you’ll need to configure them in order for Zammad to send an email.


thanks, yes it is a production environment. That’s why just trying it out is not a good idea. Thanks for the detailed addition. I’ll try it out in peace.