Install Zammad on Debian 10

Hi,

I would like to be able to install Zammad on my Debian 10 machine too.

Currently, when trying to install Zammad on Debian 10, I get the following error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zammad : Depends: libmariadbclient18 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This error says, that the package libmariadbclient18 could not be installed. When trying to install the package manually, I get the following message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  dovecot-mysql libmariadb3 postfix-mysql
The following NEW packages will be installed:
  libmariadbclient18
0 upgraded, 1 newly installed, 3 to remove and 0 not upgraded.
Need to get 782 kB of archives.
After this operation, 2,402 kB of additional disk space will be used.
Do you want to continue? [Y/n]

Since this would uninstall parts of my mailserver I am unable to install Zammad on that setup.

Is there any way to install Zammad on that setup?

Thanks and regards,
Marvin Klar

Hey @MarvinKlar - welcome back! Unfortunately Debian 10 is currently not supported. Please see https://github.com/zammad/zammad/issues/2653 and https://github.com/zammad/zammad/pull/2783 for further updates.
You can find a solution to your libmariadbclient18 issue in https://github.com/zammad/zammad/issues/2653

Hello @thorsteneckel,

thanks for the information :slight_smile: Nice to see, that its already planned. I already tried to ignore this dependency using some apt commands, but none of them worked for me. Can you give me an example, how to ignore the dependency?

Thanks and regards
Marvin Klar

Unfortunately not… Maybe @MrGeneration can help once he’s back from his vacation next week.

Sorry, but this is nothing we can solve.
This seems to be dependencies that are coming from packager.

I had similare issues when I was trying to implement sles15 (which is not possible).

Sorry, I can’t help further.

Hey @MarvinKlar . I wanted to let you know that the Debian package for stable and develop will be ready in about 30 minutes from now :slight_smile: