Incompatible database backend version

Infos:

  • Used Zammad version: This is Zammad version 6.1.0-1701163867.5a81e629.bullseye
  • Used Zammad installation type: (source, package, docker-compose, …) package
  • Operating system: “Debian GNU/Linux 11 (bullseye)”
  • Browser + version: /

Expected behavior:

  • Updating use sudo apt-get update / sudo apt-get update should update Zammad to 6.2 but receiving database error we did not get with previous versions.

Actual behavior:

  • When running sudo apt-get upgrade receiving Error: Incompatible database backend version (PostgreSQL 10+ required: 9.6.24 found)

Steps to reproduce the behavior:

  • Updating to 6.2 using deb packages.

Extra info:

PostgreSQL 9.6 and 13 are installed.
image

Could not find a reference in the release notes of 6.2 that this required PostgreSQL 10+.

In the Zammad docs for configuring the database server I could not find the upgrade path from older PostgreSQL versions. Also could not find any related topics on the community site.

I restored a snapshot and we’re back running 6.1.

Thanks for any advice how to move to PostgreSQL 10+ and letting us run Zammad 6.2.

Hi @FunkStar. Did you read this?

I did not check the prerequisites for Zammad as the install is older than Sep 2023.
According to github this changed from 9.3+ to 10+ on 27/09/2023.

Tried to open the “mg-postgresql-10” issue on git but it gives a 404

image

Still any information about going from PostgreSQL 9.6 to 10 or higher is welcome. Seems just deleting the old version (so that version 13 is the only one) isn’t working.

Thanks a lot!

edit: referring to this post, I guess updating PostgreSQL 9.6 to 13 is out of the zammad scope, since it has nothing to do with Zammad. I believe we’re on an old version because we once did an inplace update from Debian 10 to 11. I’ll try to use some guides to migrate to 13.