I lost the unprocessable_mail folder during an update

Infos:

  • Used Zammad version: 6.3.1
  • Used Zammad installation type: package
  • Operating system: debian 11

Expected behavior:

I’m looking for unprocessable emails

Actual behavior:

I have 69 unprocessable_mail in the supervision tab on zammad.

In my VM, I can’t find an unprocessable_mail folder in the /opt/zammad/tmp or /opt/zammad/var/spool folders.

I updated zammad 3 days ago and went from 5.3 to 6.3 by installing redis and apt install zammad to update zammad. The prerequisite versions are OK

can anyone help me?

Please start reading release notes. You will then understand. You should do this every time you’re upgrading your version. See:

We had this topic several times within the last weeks.

That’s what I did. and migration of the oversize_mail folder worked

You clearly did not read the 6.3 release notes.

1 Like

Yes, I did notice that the path to the files had changed. As I said in my post, I can’t find the unprocessable_mail folder in the /opt/zammad/var/spool folder.

I found this ticket: Unprocessable mail folder missing - #2 by 7qubit
As the person, the command rake zammad:email_parser:failed_email:export_all does not work, I read the doc that you send him but ,e do not understand where is the error, can you help me?

That was the change of 6.2 and is no longer valid with 6.3.

Not really. You didn’t even mention any error message so.

I tried it with and without safe mode

Rake commands are not rails commands and thus are not to be executed in a rails console. And you should never ever use safe mode “casually”. It’s a last resort switch. You’re using it wrong.

OK, ok, because the command in the doc is in the console section that starts with the rails console. i’m going to find out how to do this for the rake command

OK !!! Thank you very much

the solution is :
the unprocessable folder no longer exists since version 6.3.
you therefore need to generate the emails in the database with the command: zammad run rails rake ‘zammad:email_parser:failed_email:export_all’.

Then the emails are in /opt/zammad/tmp/failed-email-XXXX/*.eml

Do you know if there’s a way to see why an email isn’t being processed? Are there logs for each email?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.