HTTPS Apache2 configuration for zammad

Infos:

  • Used Zammad version: 2.2
  • Used Zammad installation source: (source, package, ā€¦) deb
  • Operating system: Ubuntu 16.04
  • Browser + version: Chrome, Firefox (latest)

Expected behavior:

I want to use https instead of http. I found a ticket with a working SSL configuration for apache2.4. This configuration works with letsencrypt cert, but not with our own cert.

After Installing I get allways the following error:
[authz_core:error] [pid 1992:tid 140145083500288] [client 10.20.9.7:54831] AH01630: client denied by server configuration: /opt/zammad/public, referer: https://zammad.example.at/

The strange thing is, that it works with letsencrypt.

Think this is Apache 2.4 change not zammad.

You need to modify directory tag under

/etc/apache2/apache2.conf
<Directory /opt/zammad/public>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>
1 Like

thanks for your quick reply, now it works. :+1:

Iā€™m glad it helped :smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.