How to make Zammad Highly available

I’ve deployed zammad in Kubernets EKS cluster with helm chart and want to make it highly available

  • Used Zammad version: 3.6.0
  • Operating system: k8s EKS cluster v0.17

Expected behavior:

Scale zammad-0 stetefulset and zammad-memcached to more then one replicas .

zammad-0                            
zammad-memcached-7586b976df-dztf7   
zammad-master-0                          
zammad-master-1                           

Actual behavior:

can only scale zammad-master

Steps to reproduce the behavior:

Error: UPGRADE FAILED: template: zammad/charts/memcached/templates/NOTES.txt:27:4: executing "zammad/charts/memcached/templates/NOTES.txt" at <include "memcached.validateValues" .>: error calling include: template: zammad/charts/memcached/templates/_helpers.tpl:180:51: executing "memcached.validateValues" at <fail>: error calling fail: 
VALUES VALIDATION:
memcached: replicaCount
    The standalone architecture doesn't allow to run more than 1 replica.
    Please set a valid number of replicas (--set memcached.replicaCount=1) or
    use the "high-availability" architecture (--set architecture="high-availability")

Thanks in advance .

please see; Add another webserver zammad for load balancing
As far as i understand there are currently no guides or plans to create a HA setup. of course you could make the stateless containers HA, and possibly create a multi-master/master-slave postgres/mysql instance. One thing that could be improved on tho is the startup time of the none-HA containers, and adding health checks in the standard containers to let them fail instead of linger, which sometimes seem to happen. The startup time reduction would help in the uptime, since it could sometime take quite some time to wait for the flag file, and build the caches.