How to fix 422 error - M365 readTimeout with TCPSocket closed

Infos:

  • Used Zammad version: 6.0
  • Used Zammad installation type: (source, package, docker-compose, …) package
  • Operating system: Debian 10.10
  • Browser + version:
    Chrome, Edge, Firefox, private windows, to no avail

Expected behavior:

  • After M365 authentication, users will be redirected back to the Zammad UI for handling the tickets

Actual behavior:

  • 422 M365 readTimeout with TCPSocket closed

Steps to reproduce the behavior:

This occurs to maybe 10% of our users who used personal computers, our service is open to the public so it should be working across the world. We tried to log into the outlook.office365.com for that user, then re log in to Zammad, but still the same. what could be the reason behind this?

ReadTimeout indicated a temporary connection issue in between your Zammad instance and Microsoft. That is for whatever reason.

This is most likely either an issue with machine performance (which if it’s on 100% for example might slow down responsiveness) or slow / bad routes from your network to Microsoft.

This is something that has to be fixed on network layer.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.