How change port to 8080

Hi there,
i don’t have much experience with linux, nginx etc.
But I installed zammad for debian and it works great internally.
now I want to change the port, sorry for the stupid question, but how can I change the port from 80 to 8080.
in zammad.conf I have this entry, what do I have to change here?

server {
listen 80;
listen [::]: 80;

Thanks in advance


Change this:

server {
listen 8080;
listen [::]: 8080;

service nginx restart

Open fw:

firewall-cmd --prmanent --add-port=8080/tcp
firewall-cmd --reload

Hi there,

thanks for the answer, but unfortunately it doesn’t work.

I changed the ports as described. got with “iptables -A INPUT -p tcp --dport 8080 -j ACCEPT”
but get this error message from the nginx
“nginx: [emerg] invalid port in” [::]: “of the” listen “directive in /etc/nginx/sites-enabled/zammad.conf:15”

it works if I delete the line “listen [::]: 8080;” !
where can I look where the error is?

Thanks very much

You can delete this line.
It’s for IPv6, and I guess it’s not used by you.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.