Hide "Groups" from "New Ticket" page

Feature Request: Hide the drop down menu “Groups” when opening new ticket

Hi team,
my need would be to hide the drop-down menu in question and work with automatic triggers.
To give an example: I created a “category” object, where the user can choose from different fields (Hardware, Software, etc…). I would like to manage the group assignment based on the category chosen by the user with triggers (which is already possible to do).

For this reason, I am trying hard to hide the “Groups” choice, because we want to manage them internally, the user should not be able to choose which group to open the ticket for.

I tried to edit it manually under System → Objects → Request, but “Groups” is grayed out and therefore not editable.

Another use case might be in a multi-tenant environment, where I create a group for each tenant, and I would like to prevent tenant X from being able to open a ticket for tenant Y.

Thank you for your great work.

You can do that via core workflows.

see Admin → Core Workflow, there you can hide the group field and also select a group based on a category.

1 Like

Hi rolfschmidt, thanks for your reply.
I tried with this setting in workflow:
Object: Ticket
Context: Creation Mask
Action: Group → hide
Action 2: Group → set as optional
Stop at correspondence: No
Priority: 500

When I try to create a ticket, I’ve got the error “The required value ‘group_id’ is missing”.
I also tried to set a group as default via workflow, but I’ve got the same error
Could you help me?


PS: I apologize for the probably wrong translations, but I use zammad in Italian

Update: I tried setting it only as optional, the asterisk disappeared, but it is still mandatory.

The group is mandatory to a Zammad ticket, you cannot keep it unset.
If that’s not what you’re doing exactly, note this known and fixed bug: Core Workflow: Removing groups with re-adding some discards all permissions the user has · Issue #5002 · zammad/zammad · GitHub

As you didn’t state your Zammad version it’s hard to tell at what point you are.

Hi MrGeneration,
sorry, I have 2 installations: 1 with 5.2.3 and the other with 6.0.0
However, I was able to solve it.
I used to try with the option “Set Statically,” but the group was not set.
Today I also noticed the “Select” option, and that way it works.

Thank you for the support

Both versions are outdated - but 5.2 is the worst in this situation. Upgrade asap.