FQDN not replaced in ngnix config


  • Used Zammad version: 4.1
  • Installation method (source, package, …): yum
  • Operating system: CentOS Linux release 7.9.2009 (Core)
  • Database + version: -
  • Elasticsearch version: -
  • Browser + version: -

Expected behavior:

Changing the “Fully Qualified Domain Name” under Settings → “System” should replace the FQDN in all config files.

Actual behavior:

Changing the “Fully Qualified Domain Name” under Settings → “System” does not change the hostname in the ngnix-config file (/etc/ngnix/conf.d/zammad.conf) so doing a http-call to your old FQDN will redirect you to the old FQDN with https.

server {
listen 80;
server_name oldfqdn.domain.com
return 301 https://oldfqdn.domain.com$request_uri;

Steps to reproduce the behavior:

Change the FQDN of Zammand via GUI, do a http-call to the old fqdn.

Not asking for technical assistance, would just want to know if this feature works as designed or sometings wrong?

Zammad runs as unprivileged user.
This user is different from your web servers unprivileged user.

Webserver configuration files usually only have r/w permission for privileged users (for very good reasons). This would mean Zammad would require higher privileges to adjust your webserver configuration.

Even worse, users could use different web servers than those we officially support (yes, there are those users). We can’t update web server configuration files for you, because there are a lot of variables we can’t always know about. Every system is configured different.

Changing Zammad settings affects Zammad only - if you change the FQDN setting, you’re required to put that changed into your configuration files manually. That’s out of the application scope.

I know very little environments that would do that automatically for you - however, those application scopes are a lot of different than ours.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.