Fonts don't load on newest version (404)

Infos:

  • Used Zammad version: 5.0.3-1639556157.cf2d8dc8.buster
  • Used Zammad installation type: package
  • Operating system: deb10
  • Browser + version: Chrome, Edge (Chromium), Firefox - all newest version

Expected behavior:

  • Fonts load correctly

Actual behavior:

  • Fallback to Helvetica Arial

Steps to reproduce the behavior:

  • Update to newest version and have a look(?)

Explanation:

I updated yesterday from 5.0.3-1639085449.b757f8e2.buster to the above build and was shocked when i didn’t see lovely FiraSans anymore :frowning: .

All browsers are somehow not able to get the fonts anymore (Chrome example):
2021-12-16 07_11_32-DevTools - ticketsystem.sv.nr_

The url the browser is trying to reach still is:
https://$myhostname.$mydomain/fonts/$fontfile

The files still exist on the server:

07:15:54 root@lx-zammad:/opt/zammad/public/assets/fonts$ l
total 4.4M
-rw-r--r-- 1 zammad zammad  18K Dec 15 10:12 glyphicons-halflings-regular.woff2
-rw-r--r-- 1 zammad zammad  23K Dec 15 10:12 glyphicons-halflings-regular.woff
-rw-r--r-- 1 zammad zammad  45K Dec 15 10:12 glyphicons-halflings-regular.ttf
-rw-r--r-- 1 zammad zammad 107K Dec 15 10:12 glyphicons-halflings-regular.svg
-rw-r--r-- 1 zammad zammad  20K Dec 15 10:12 glyphicons-halflings-regular.eot
-rw-r--r-- 1 zammad zammad 125K Dec 15 10:12 FiraSans-Regular.woff2
-rw-r--r-- 1 zammad zammad 178K Dec 15 10:12 FiraSans-Regular.woff
-rwxr-xr-x 1 zammad zammad  26K Dec 15 10:12 firasans-regular-webfont-a1c53cbcd8f6b5dd419e69baff337383.eot
-rwxr-xr-x 1 zammad zammad  71K Dec 15 10:12 firasans-regular-webfont-39d7571f67e40601a3c7bb8146af339f.ttf
-rwxr-xr-x 1 zammad zammad  29K Dec 15 10:12 firasans-regular-webfont-326b4b46e8b5f04059ea4ea96da1de39.woff
-rwxr-xr-x 1 zammad zammad 100K Dec 15 10:12 firasans-regular-webfont-27e62a02ccd15c3f3ec82a5b07c68810.svg
-rw-r--r-- 1 zammad zammad 390K Dec 15 10:12 FiraSans-Regular.ttf
-rw-r--r-- 1 zammad zammad 153K Dec 15 10:12 FiraSans-Regular.eot
-rw-r--r-- 1 zammad zammad 129K Dec 15 10:12 FiraSans-Medium.woff2
-rw-r--r-- 1 zammad zammad 181K Dec 15 10:12 FiraSans-Medium.woff
-rw-r--r-- 1 zammad zammad 391K Dec 15 10:12 FiraSans-Medium.ttf
-rw-r--r-- 1 zammad zammad 157K Dec 15 10:12 FiraSans-Medium.eot
-rw-r--r-- 1 zammad zammad 126K Dec 15 10:12 FiraSans-Light.woff2
-rw-r--r-- 1 zammad zammad 177K Dec 15 10:12 FiraSans-Light.woff
-rwxr-xr-x 1 zammad zammad  71K Dec 15 10:12 firasans-light-webfont-ee192366bb30edc80ed1168eb2ce44ba.ttf
-rwxr-xr-x 1 zammad zammad  28K Dec 15 10:12 firasans-light-webfont-8f6d166b428b8c4df0fc8ca43c2622cc.woff
-rwxr-xr-x 1 zammad zammad  26K Dec 15 10:12 firasans-light-webfont-72b19bb8b5524e54077bc0a37e9332ec.eot
-rwxr-xr-x 1 zammad zammad 100K Dec 15 10:12 firasans-light-webfont-3c22e83bb9d69299a0119909eb054741.svg
-rw-r--r-- 1 zammad zammad 383K Dec 15 10:12 FiraSans-Light.ttf
-rw-r--r-- 1 zammad zammad 153K Dec 15 10:12 FiraSans-Light.eot
-rw-r--r-- 1 zammad zammad 136K Dec 15 10:12 FiraSans-Bold.woff2
-rw-r--r-- 1 zammad zammad 192K Dec 15 10:12 FiraSans-Bold.woff
-rwxr-xr-x 1 zammad zammad  26K Dec 15 10:12 firasans-bold-webfont-dbb0e92d31531ddaa5e55dedb9761edb.eot
-rwxr-xr-x 1 zammad zammad  29K Dec 15 10:12 firasans-bold-webfont-877d21cf99f300b8680ef77d12a98b57.woff
-rwxr-xr-x 1 zammad zammad  71K Dec 15 10:12 firasans-bold-webfont-84efee074704b5fb303303e922a131cd.ttf
-rwxr-xr-x 1 zammad zammad 100K Dec 15 10:12 firasans-bold-webfont-0eb0f6eca42625f8184372baf62c255b.svg
-rw-r--r-- 1 zammad zammad 423K Dec 15 10:12 FiraSans-Bold.ttf
-rw-r--r-- 1 zammad zammad 166K Dec 15 10:12 FiraSans-Bold.eot

Is anyone else experiencing this?
If not i might have to take a deeper look into this on my environment.

cheers

Yes I have the same problem. I was very surprised that the font changed and then I saw the error in the browser dev tools.

When I try to open the font directly I get this

grafik

Definitely looking fishy.
Reason unknown, verified and filed as bug already.

@svnr-dvnkln I was so keen and burned contract time. :woozy_face:

2 Likes

The issue has been fixed in stable and is available per package repository already.
(Note: Debian 9 currently still runs in processing).

Docker-compose doesn’t seem to have started building yet.

2 Likes

Confirmed, thanks for the quick reaction :+1:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.