Fehler beim Einrichten eines SMTP-Hosts

Hallo,
ich versuche, einen SMTP-Host einzutragen, welcher nur Domain-intern Mails versenden kann, auf Port 25 ohne Authentifizierung. Wir Zammad rein intern betreiben und hier macht uns nun der Einrichtungsassistent in Zammad Probleme. Zammad möchte eine Testmail die Adresse emailtrytest@znuny.com senden, was mit einem “554 5.7.1 relay access denied” abgewiesen wird. Was kann ich tun, um diese Testmail zu umgehen oder eine interne Adresse für diesen Test einzutragen?
Freundliche Grüße
Dirk

Hi,
I am trying to enter an SMTP host, which can only send mail within the domain, on port 25 without authentication. We run Zammad purely internally and the setup assistant in Zammad is now causing us problems. Zammad would like to send a test mail to the address emailtrytest@znuny.com, which is rejected with a “554 5.7.1 relay access denied”. What can I do to bypass this test mail or to enter an internal address for this test?
regards
Dirk

Sorry i don’t really speak German. But generally relay access denied, means your smtp server doesn’t allow to send emails to other domains or from certain origin’s, than the configured one. Best way is to consult the documentation of your smtp/mail server on how to enable relaying.

Danke für ihre Antwort. Das ist aber leider nicht der beste Weg. Unser SMTP Server ist unantastbar, da habe ich keine Chance. Kann ich den Test nach extern nicht irgendwie unterbinden?

Thank you for your reponse. Unfortunately, this is not the best way. Our SMTP server is inviolable, I have no chance. Can’t I somehow prevent the external test?

well i believe the test is to just do a functional test, so if you make sure zammad send’s with an address which is allowed by your mail server, this test should succeed. Also make sure that zammad is able to read from that address, since it expect’s the mail it send, to be received and readable by zammad

But how can I use an adress, which is allowed? The address emailtrytest@znuny.com is hardcoded in /opt/zammad/lib/email_helper/probe.rb line 308. (zammad/probe.rb at c71b0d36d4fcefdaae4e39f1859094727a3ca74c · zammad/zammad · GitHub)
The problem for me is, to change the line in my docker-installation. How can i do it?
Or could i solve the problem otherwise?

for me it seems to come land at the if…not the else, since i receive them with the configured smtp address;

i’m using the docker-compose as well and i didn’t need to change anything related for the emailing.

Jetzt habe ich das Problem gelöst. Ich habe in der Datei probe.rb die Emailadresse auf eine interne Adresse unserer Domain geändert und schon hat der SMTP-Server akzeptiert. Danke vielmals für die Hilfsbereitschaft.

Now I have solved the problem. I changed the email address in the file probe.rb to an internal address of our domain and the SMTP server has already accepted. Thank you very much for your willingness to help.

Just as a sidemark: This is a english speaking community. Please write your next posts in english only.