Extend with additional gems


  • Used Zammad version: 4.1
  • Used Zammad installation type: package
  • Operating system: Debian 10

Expected behavior:

  • extend Zammad with additional gems

Actual behavior:

  • Error when additional gems in Gemfile.local

Steps to reproduce the behavior:

# Want to extend Zammad with additional gems?
# ZAMMAD USERS: Specify them in Gemfile.local
#               (That way, you can customize the Gemfile
#               without having your changes overwritten during upgrades.)

I created the file Gemfile.local and entered gem 'mySpecialGem' in it

If I now run zammad run rails c I get the message

You are trying to install in deployment mode after changing
your Gemfile. Run `bundle install` elsewhere and add the
updated Gemfile.lock to version control.

If this is a development machine, remove the /opt/zammad/Gemfile freeze
by running `bundle install --no-deployment`.

The list of sources changed
The dependencies in your gemfile changed

You have added to the Gemfile:
* mySpecialGem

When I run zammad run bundle install --no-deployment I get the same message

In 4.0 the --no-deployment option works

How can I add additional gems in 4.1?

1 Like

This should do the trick:

zammad config:set BUNDLE_DEPLOYMENT=0
zammad run bundle install --no-deployment

However, note that this may change in the future due the nature of ruby on rails moving forward as well.
Use with caution.


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.