Error when trying to confiure office365 smtp on initial setup for notifications

I’m getting an error: “STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied;” when trying to configure smtp server on initial setup for notifications. I understand what is the cause, smtp server doesn’t allow to use different sender e-mail but the problem is that I can’t configure any on initial form, so Zammad is using its own like “me@…” (saw in debug console).

Am I right or I missed something?

Can you provide your production.log and a screenshot of the SMTP configuration that you’re trying to set up?

This is already the error exchange delivers.
Your account is not allowed to send as the email address you configured.

1 Like

@benmo I configured it after initial setup, changing sender e-mail to the correct value (from default one which I didn’t set)
@MrGeneration But I didn’t set any e-mail address on initial setup. Just filled SMTP data.

True.
By default Zammad sets your notification sender to “noreply@{fqdn]”
While fqdn is the FQDN of your Zammad installation.

See https://admin-docs.zammad.org/en/latest/channels/email/settings.html

So if I could provide this sender e-mail address on initial SMTP setup I could finish with success instead I end up with failure.
I don’t understand (I don’t know details about SMTP) why you consider using required/configured sender e-mail address by its provider as an error?

I don’t really understand what you mean. If you want to use SMTP to deliver your notifications, the specified SMTP user must be able to send email from the email address that is set in the email settings.

Microsoft 365 doesn’t allow sending emails from aliases or other email addresses, so you need to create a new shared mailbox, like noreply@example.com, authenticate with this user to MS365 and set the notification email address in the email settings to noreply@example.com as well.

Hope I understood your issue correctly and was able to help.