Error Upgrding Zammad 3.1 to 4.0

Infos:

  • Used Zammad version: 3.1
  • Used Zammad installation type: package
  • Operating system: Centos 7
  • Browser + version:

Expected behavior:

Upgrade to version 4 as a set before upgrade to 5
yum update zammad-4.0.0-1616652753.1200cd9d.centos7.x86_64

Actual behavior:

Dependency Error

—> Package zammad.x86_64 0:3.1.0-1562942376.fb3e2d49.centos7 will be updated
—> Package zammad.x86_64 0:4.0.0-1616652753.1200cd9d.centos7 will be an update
→ Processing Dependency: elasticsearch|elasticsearch-oss for package: zammad-4.0.0-1616652753.1200cd9d.centos7.x86_64
→ Finished Dependency Resolution
Error: Package: zammad-4.0.0-1616652753.1200cd9d.centos7.x86_64 (zammad)
Requires: elasticsearch|elasticsearch-oss
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

What should i do ?

Well it says elasticsearch is missing so maybe update elasticsearch first?

No , updating elasticsearch not solve this issue

Hi , i am still stuck with this issue any one can help ?

Hello!

Are you follow this guide?
Set up Elasticsearch — Zammad documentation

Here the compatibility versions against Zammad vs Elasticsearch: Software — Zammad documentation

All documentation is from: Install from package — Zammad documentation