Error in Mobile Site

Infos:

  • Used Zammad version: 6.2.0-1706605597.530c7efe.jammy
  • Used Zammad installation type: (source, package, docker-compose, …) Package
  • Operating system: Ubuntu 22.04.3
  • Browser + version: Chrome

Expected behavior:

  • Update ticket on mobile site/app

Actual behavior:

  • Chrome app displays Aw, Snap! message

Steps to reproduce the behavior:

  • When I try to change the state of a ticket on the mobile version of the site it takes me to the error page with a reload button. I tried removing the installed app and doing it through Chrome (on android) as well.

I checked the production.log file and am not seeing any errors.
Is there anywhere else I can look to find the cause of this?
I’ve updated and restarted the server and the error persists.

With this small information, we can not say anything.

You should maybe describe some more about your setup, e.g. what kind of permissions and so on

You could also check the browser console, if there is some error visible. Would also be nice to see what kind of error on the error page is shown.

Thank you for replying.

I enabled USB debugging and tried to view the error through chrome on a PC but it does not display any errors in the console.
I thought maybe it was because the Chrome versions didn’t match so I updated it on my Android device.
Then the State button worked properly but only 1 time!
Also, I can still not see any errors in the console.

I’ve tried clearing the cache/cookies for the site and also opening it in a incognito tab but neither helped.

I also deleted my entire Android Chrome data which also did not work.

I just tried it on the Samsung Android browser and it works properly but I do not want to use this browser and I like the “app version” of the mobile site that Chrome installs.

This isn’t a deal breaker for me because I can close the tickets from a PC but I would like to resolve this issue if possible.

Edit:
Sorry I forgot mention I have full admin and agent permissions for my login.
We are also using the ldap feature for our logins.

But when I understood it correctly, it’s only not working in the Chrome mobile browser on Android. And with the Samsung Android browser, it’s working?

Thank you for replying.

Yes that is correct.

The Samsung Android browser works correctly.
I just tried Android Firefox and it also works correctly.

I tested Chrome again and it is giving the same problem.

What are you doing in detail?

Switching the state field and then clicking the “Save”-Button?

Normally, when something is broken with the request, it should be visible in the console. Is the ticket updated correctly afterward?

When I tap the State field a few seconds go by and then the error page appears.
It does not give me the list of states and I do not have the ability to tap anything else.
Once the error page comes up I can tap Reload which takes me back to the previous page.

I have also discovered that the same behavior occurs with the Priority and Owner fields.
There are also issues when trying to enter the Tags screen.
It seems like anything in the Ticket Information screen will give me this issue.

Every once in a while it seems to work (but only once then back to the same error). I’m wondering if there could be a timeout of some kind happening?

I have reviewed the recommended performance and database settings. Neither have made a difference.

But you don’t have error messages, about a missing web socket connection?

You could setLogLevel("debug") in the browser console and check if some additional information is visible which could help.

Thank you.
I’m not sure if this is what you meant but I set the log to Verbose (All levels) in the drop down to the right of the filter box in the console.

I am able to control the site through the remote view in the console also so I know that it is connected properly.

It still does not show any errors or other entries in the console while testing the site.
Also, the remote view does not show the Aw, Snap! error page when it comes up on the phone. But immediately refreshes when I tap the Reload button on the Aw Snap! page.

Is there another option I am missing?

I forgot to mention previously, this is a Samsung S10, Android 12 with the latest Chrome installed.
I have tested it both on cellular data and Wifi.
I am finding no other issues with our install. Everything seems to work correctly on PC browsers and the Android Samsung and Firefox browsers.

Also, the desktop version of the site works fine on the Android Chrome browser.

Another update:
I decided to try the Samsung “Secure Folder” version of Chrome on my device and it is working properly!

Same version of Chrome (121.0.6167.143)

So now I just need to figure out what the difference is between these two.

I figured it out.

I use Bitwarden on my device.
Once I turned off Bitwarden in the Accessibility features it started working normally.

Any suggestions for getting these to work together?

We have no control over thirdparty addons in Browsers and what they’re doing in applications in terms of manipulating HTML structures etc.

Thank you.

It’s actually not an add-on for Android Chrome. (I don’t believe Android Chrome can use add-ons at all)

It’s an add-on for Android. I’m not an expert on it but I think the accessibility option allows the program to auto-fill login information in an OS and apps that don’t support it natively.

After reading over information about it seems I don’t need it to be enabled with Android 12 anyway.

Thank you again for your assistance.