ERROR -- : Can't use Channel::Driver::Smtp: #<EOFError: end of file reached>

Infos:

  • Used Zammad version: 4.1.x
  • Installation method (source, package, …): Package
  • Operating system: Debian GNU/Linux 10 (buster)
  • Database + version: (PostgreSQL) 11.14 (Debian 11.14-0+deb10u1)
  • Elasticsearch version: 7.x
  • Browser + version: MS Edge, Chrome, Firefox newest versions

Expected behavior:

  • We created an automation task that will send an close notification e-mail to the customer of the ticket.
  • We expected that Zammad will send E-Mails to all customers of alle closed tickets.

Actual behavior:

  • Zammad system shows following error message:
  • ERROR – : Can’t use Channel::Driver::Smtp: #<EOFError: end of file reached>

Steps to reproduce the behavior:

  • Create an automation task that will send E-Mails to the customer if the ticket is closed.
1 Like

Same problem here when trying to set up smtp relay for outbound email channel. I used the docker-compose set up.

Hello again,

it seems that this problem occurs when some batch processing of tickets or a batch of some timed tickets are opened synchronously.

We just investigated that there are message rate limits with microsoft exchange:
Message rate limits and throttling | Microsoft Docs

Maybe it is somehow possible to let batches of tickets to be processed with some time delay?

Best regards

Okay i´ve found out that my SMTP relay does not used SSL/TLS and there is no option to disable the usage of SSL/TLS in the email channels settings.