Error 422: The change you wanted was rejected [Office 365] [Docker-compose]

Infos:

  • Used Zammad version: latest
  • Used Zammad installation source: docker-compose
  • Operating system: centos / docker
  • Browser + version: firefox

Expected behavior:

Login with Office 365 Credentials on zammad.

Actual behavior:

Getting error 422: The change you wanted was rejected

Steps to reproduce the behavior:

Install Zammad with docker-compose and use traefik as reverse proxy.
https://github.com/zammad/zammad-docker-compose
My docker-compose.prod.yml

version: ‘2’
services:

zammad-nginx:
environment:
- VIRTUAL_HOST=example-zammad.com
labels:
- traefik.enable=true
- traefik.http.routers.zammad-http.entrypoints=web
- traefik.http.routers.zammad-http.rule=Host(example-zammad.com)
- traefik.http.routers.zammad-https.tls.certresolver=myhttpchallenge
- traefik.http.routers.zammad-https.entrypoints=web-secure
- traefik.http.routers.zammad-https.rule=Host(example-zammad.com)
- traefik.http.middlewares.zammad-http-redirectscheme.redirectscheme.scheme=https
- traefik.http.routers.zammad-http.middlewares=zammad-http-redirectscheme
- traefik.docker.network=web
networks:
- default
- web

networks:
web:
external:
name: web

I created o365 token as following: https://admin-docs.zammad.org/en/latest/settings/security/third-party/microsoft.html

I have seen a similar issues where that helped:
RequestHeader set X_FORWARDED_PROTO 'https' RequestHeader set X-Forwarded-Ssl on
https://github.com/zammad/zammad/issues/2758

Is there a possibility to use the env variable in the compose file for these headers?

At this very moment the only option is to use your own nginx container that does the communication.
However, this is subject to change in the future, see: https://github.com/zammad/zammad-docker-compose/issues/120

Thanks for the fast reply!

When do you think this is going to change?
I can live with local accounts till then. :smiley:

I am sorry, I can’t forecast this.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.