Emails sent by Trigger or System Notification not threading in email client (email conversation threading)


  • Used Zammad version: 5.4.1
  • Used Zammad installation type: docker-compose
  • Operating system: dockerhost is Rocky Linux 9
  • Browser + version: client browser is Edge. Email testing is being done with M365 Outlook web client

Expected behaviour:

  • All emails sent from Zammad that are relating to a specific ticket should be in a thread in the customer’s email client
  • In other words, all emails sent from Zammad relating to a specific ticket would be in a single conversation in Outlook, similar to a conversation between two employees
  • This email thread / conversation would include emails sent by Zammad trigger, as well as replies from any agent that sends an email reply in the Zammad web UI
  • This email thread also includes the first email sent by the customer, which is what creates the email

Actual behaviour:

  • The first email sent by the customer to request help and create a ticket is not threaded
  • Any email sent by a Zammad trigger is not threaded in Outlook
  • If multiple agents reply to the ticket in Zammad webui, their replies are not consistently threaded in Outlook

Steps to reproduce the behaviour:

  • Install a fresh copy of zammad-docker-compose
  • Install docker-mailserver
  • Configure Zammad email channel
  • Enable all 3 default Triggers (auto reply on new ticket and follow up, and notify of owner change)
  • Using M365 Outlook web ui, send an email to to create a ticket

Why is this a problem?

  • It’s a small usability issue for customers that only submit tickets through email, and never login to Zammad
  • I would like to enable more Zammad Trigger email notifications, to notify these customers of changes on their ticket. But because the Zammad emails do not thread, it creates a lot of clutter in customer inbox

What I have tried:

  • Searched Zammad forum - I was not able to find a single discussion on this topic
  • Reviewed Zammad settings and documentation. Was not able to find any setting that seems like it would help with this issue
  • Tried switching the System Notification email to (previously we left it as the default, But the exact same threading behaviour happens either way
  • Reviewed email headers in Outlook to try and find out why Zammad System Notification emails are never threaded. But was not successful

Workaround: Use full quote

  • I would prefer not to use full quote
  • Enabling full quote does not solve the problem caused by no threading - the email inbox will still be cluttered
  • In my opinion the Zammad default setting of having full quote disabled is correct. Adding a bunch more information to each email makes the reading experience worse
  • Email full quote feature documentation

Photos to demonstrate the issue: