Email notification to customer not working


  • Used Zammad version: 5.1.x
  • Used Zammad installation type: package
  • Operating system: Red Hat Enterprise Linux release 8.5
  • Browser + version: Firefox latest

Expected behavior:

  • Sending notification emails to the Customer when the ticket is created or modified

Actual behavior:

  • The email is sent correctly to members of the Agent group but is not sent to the customer who opened the ticket

Steps to reproduce the behavior:

  • Create a ticket as customer
  • Agent received a notification
  • no email is sent to customer

Hello guys, i am asking for help about this problem.
Triggers are configured correctly, in fact I can see following log when customer create a ticket (vlfusco@xxxx is the email of the customer who created the ticket):

INFO – : Send email to: ‘vlfusco@xxxx’ (from “noreply.itsm-iam” noreply@xxxx)

About email configuration I’ve configured “Email Notification” with our SMTP server. The connection test is ok and email to Agents is sent correctly.
About “Email Accounts” session I’ve followed this link (Dispatch messages with Sendmail — Zammad documentation) for configure an only outgoing email account.

I also tried this solution (How to send notification by email to customer) but no luck (every group has an email configured)

Despite everything seems to be configured correctly, our smtp server doesn’t receive any mail request for vlfusco@xxxx but only for Agents.

Could you please help me and explain how email notification works exactly?

Thank you in advance

Best Regards,
Valerio Fusco

If you configured your mail channel to use a local sendmail or postfix installation, did you check your postfix or sendmail queue if the mails are in there? Did you configure the local sendmail or postfix to forward all mails to your smtp server?

Thank you for your answer.
I’ve tried to configure a local postfix server and just after started it all email has arrived!!!
I can’t explain why this behaviour because I’ve configured an external smtp server and I did it because I don’t want to manage an additional local service!
Could you please explain me why? I still don’t understand how email configuration works in Zammad…
Thank you in advance.

could you check the trigger setting on new ticket created?

There are two seperate e-mail configurations in Zammad that are configured under Channels → E-Mail. At the bottom you configure the SMTP server that is used for automatic agent notifications. At the top you configure an incoming mailbox for incoming tickets that are sent by customers per e-mail to your helpdesk, and an outgoing mailserver that is used for all communication with the customer, and all communication done by triggers or the scheduler. You have to have at least an outgoing mailserver configured in both sections.
How you deliver outgoing mail is up to you as the administrator and you should have an idea of what you are doing if you want to self host a Zammad installation. You can either directly connect to an smtp server or you can use a local MTA on your Linux server that relays the e-mails to another server but it’s up to you to configure this correctly. The guides you linked to only show you how to setup the top section without an incoming mailbox but you still need to know which parameters to enter for the smtp server you wish to use.

it has default values

Thank you very much for the explaination!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.