Email notification setup error: 550 5.1.0 Sender is not allowed to send from support.mydomain.com (R2)

Infos:

  • Used Zammad version: 5.3.1-1672769502.c29df3bd.focal
  • Used Zammad installation type: package
  • Operating system: Ubuntu 20.04
  • Browser + version: edge, brave

Expected behavior:

  • successfull configuration of email notifications

Actual behavior:

  • when I try to setup email notifications I fill out the information and recive the following error.

“”"
error of: 550 5.1.0 Sender is not allowed to send from support.mydomain.com (R2)
“”"

  • application.log doesn’t container any errors

note I did some sanitiation, but all info in the json was correct.
“”"

Processing by ChannelsEmailController#notification as JSON
Parameters: {“adapter”=>“smtp”, “options”=>{“host”=>“[myemailhost]”, “user”=>“support@[mydomain]”, “password”=>“[FILTERED]”, “port”=>“[port]”}, “channel_id”=>2}
Completed 200 OK in 781ms (Views: 0.3ms | ActiveRecord: 2.8ms | Allocations: 8800)

“”"

  • this is the same email account that I used in the “Email Accounts” and it connected successfully, and can send emails, when replying to tickets.

Thank you in advance for any help.

Update:

if I go into system, and remove the subdomain int he fqdn. from what was “support.mydomain.com” to just “mydomain.com” it works, It is trying to send mail from that fqdn domain. This is my issue as my smtp is expecting just “mydomain.com” and zammad is using the fqdn of this server “support.mydomain.com”.

Is there anyway to have zammad just use my root domain of “mydomain.com” instead of “support.mydomain.com” just for this outbound email?

okay, it was infront of me this whole time. I can only hope that this saves someone else some time in the future.

in Settings → Channels → Email → Settings → Notification Sender you can change the send email for the notification.

2 Likes