Email bounced by AWS SES when S/MIME signed

Infos:

  • Used Zammad version: 5.4.0-alpha-1668170740.4aab4543.bullseye
  • Used Zammad installation type: package
  • Operating system: Debian 11
  • Browser + version: any

We have recently switched to AWS SES as a relay host for outgoing mail and since then we are seeing this error:

8E11B7F5: to=<someone@gmail.com>, relay=email-smtp.eu-central-1.amazonaws.com[3.127.127.152]:587, delay=0.64, delays=0.05/0.01/0.34/0.25, dsn=5.0.0, status=bounced (host email-smtp.eu-central-1.amazonaws.com[3.127.127.152] said: 554 Transaction failed: Expected disposition, got null (in reply to end of DATA command))

This bounce happens only with AWS SES (the mail is sent to our SMTP Postfix that uses AWS SES as a relayhost. Our server doesn’t seem to care about this error when sending a copy to internal recipients like agents).

The error happens only with S/MIME signed emails. If we disable the S/MIME signing, the email goes through AWS SES without problems.

I’ve tried to look at the email content: I do not see anything strange, the email structure looks fine to me, but I’m not an email expert.

Anyone having the same problem? For now we solved it by simply disabling the S/MIME signing, but having the X509 certificate ready it’s a pity not being able to use it.