Elasticsearch Version Question

Server Details:

  • Used Zammad version: 2.9
  • Used Zammad installation source: deb
  • Operating system: ubuntu 18.04
  • Browser + version: latest

Good Day,

To All,

I saw on latest documentation how to install the elasticsearch is now version 7. (ubuntu)
https://docs.zammad.org/en/latest/install-elasticsearch.html#install-elasticsearch

Because before i saw some user have problem after upgrade to the latest version.

My question is now is the elasticsearch version 7 with with ingest-attachment plugin is compatible in zammad 2.9 or 3.1

Now our server running on elasticsearch 5.6.16 version. it is possible to update? or upgrade for zammad? if yes requesting for your kind assistance how to upgrade for zammad.

Thank You

Heya, welcome back :slight_smile:

Elasticsearch 6.x and 7.x support has been introduced with Zammad 3.1, so if you have a older Zammad version, you need to upgrade it first.

Regarding upgrading Elasticsearch: Yes, it is possible, however, please note that there’s an upgrade path: https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-upgrade.html

Upgrading ES is out of scope of the documentation which is why the above link is only linked in our docs. :slight_smile:

1 Like

Good Day

yeah its been a while, but i always monitor the latest update on zammad… and nice work zammad team…our 2.9 version runs smoothly sometimes we have an error but its solved by searchindex:rebuild or restarting all the services. i saw all new commit on GitHub and preparing for update to zammad 3.1 or wait for the 3.2 also to upgrade the elasticserch .

@MrGeneration thank you Sir for clarifications and prompt response…

More Power and God bless…

1 Like

Hi there :wave:t2:

After upgrading from 5.6 to 6.8 I’m getting the following error:
warning: Falling back to java on path. This behavior is deprecated. Specify JAVA_HOME

Elasticsearch won’t start—did I do anything wrong?

This is not an error but a warning.
Just specify the variable implied with the java path and you’ll be fine? :slight_smile:

Elasticsearch won’t start (since upgrading to 6.8), though. Any ideas?

â—Ź elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2019-12-13 15:01:56 CET; 6h ago
     Docs: http://www.elastic.co
  Process: 2075 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 2075 (code=exited, status=1/FAILURE)

Dec 13 15:01:55 portal systemd[1]: Started Elasticsearch.
Dec 13 15:01:55 portal elasticsearch[2075]: warning: Falling back to java on path. This behavior is deprecated. Specify JAVA_HOME
Dec 13 15:01:56 portal systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Dec 13 15:01:56 portal systemd[1]: elasticsearch.service: Unit entered failed state.
Dec 13 15:01:56 portal systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

Just a (very late) follow-up regarding my issue after upgrading Elasticsearch. The error message was something like:

MESSAGE=/usr/share/elasticsearch/bin/elasticsearch-env: line 75: /etc/default/elasticsearch: Perm

And yes, for some unknown reason the permissions were:

-rw-rw---- 1 root root 1613 Nov 26 02:18 elasticsearch

After changing to 644 (a.k.a -rw-r–r--) it did indeed work.