E-Mail Channel. Set sender as Customer


  • Used Zammad version: 2.4
  • Used Zammad installation source: (source, package, …) deb
  • Operating system: Ubuntu 16.04
  • Browser + version: any

Expected behavior:

  • If an agent send a ticket via mail, it should set the sender as customer

Actual behavior:

Steps to reproduce the behavior:

  • Set up an E-Mail Channel and check if the settig “Customer selection based on sender and receiver list” is set to yes
  • send a mail to the definied mail address
  • look whats happening :slight_smile: (the customer is ticket and not chef)

One thing. I have set up this e-mail address. Our agent will be always synced via the LDAP integration. After I synced the AD I saw that i have made a mistake with the ldap filter and the user ticket was also synced. So ticket is an agent. I have deactived it. Could this be a problem?

In version 2.3 it works like a charm.

Thanks for your help, again :slight_smile:

Hey @schmanat,

so you, as an agent, are sending an email to ticket@domain.com?

There’s a setting for this in E-Mail - Settings (since i know you’re german speaking this screenshot will probably do):

Is that what you’re looking for?

If it’s not, have a look at E-Mail - Accounts and make sure ticket@domain.com is configured correctly as an ingoing email-address. We had that problem too.


Thank you for your replay @svnr-dvnkIn

I have set this setting, in version 2.3 it works. So i think I have configured it the right way. Since 2.4 it seems to be broken.

I also have a look into the E-Mail Accounts and this Account is defenitly an ingoing e-mail account.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.