Dynamic fields in tickets

Hi all,
I’ve a question on how to set up dynamic fields in tickets for a customer. I want certain fields to show up once a customer chooses a certain category and disappear when the user choose a different category.

I followed the instructions in the documentation but no joy. I’m not sure if I’m doing something wrong.

I first added a few objects to tickets and under the Core Workflow with action set to show the field when the category is selected but Zammad keeps showing all the fields to the end user.

Is it just me? am I doing something wrong? Did anyone manage to get it to work in their company who can share some tips.

Thanks in advance.

1 Like

I tried to test this and also can’t get it to work.

It works when I put it in “saved conditions” but it doesn’t when I try “selected conditions”. I guess I am doing something wrong but don’t know what.

This is currently the only workflow active.

Thanks,
Gijs

1 Like

Thank you so much for your feedback. I’m gonna report it to Zammad as a bug and wait for their response.

1 Like

@hewawo5849 @ecomsilio

I got this to work by unchecking the ‘Shown’ box on the objects themselves prior to or after adding them to the core workflow.

Then in my core workflow I set the object to ‘shown’ and another line for mandatory, another for the default setting.

image

4 Likes

you can create a workflow, which hides everything and only show the first option the user needs and set it to prio 1

Thank you so much for your reply AdrianA

I tried what you suggested but it didn’t work for me.

I set up a an object called category and set the type to tree and checked the shown option.


Then created multiple other objects one of which is called software and uncheck the shown option on those.
Then I set up a workflow to show the object Software (type select) when the user choose software but it still doesn’t show it on the ticket (I tried putting it in both the Selected conditions and saved conditions but neither of them worked)

Hi Armin,

Thank you so much for your response. The problem for me is that both option are not working when setting up a workflow. I’m most like doing something wrong but I can’t seem to figure out what it is,

To clarify:
You setup your tree select and have it set to show on create and edit, which it does.

You have another object setup called software, I assume with different values than the tree select, with no boxes checked for create or edit.

You have a core workflow setup with saved condition and the Software and subtypes selected, and the action being to show your software object.

This is telling the system to not show software until after you update the ticket. If you instead put it under selected conditions and then save your workflow it should be working. Also, if you already have a ticket open in a tab and update the workflow I’ve found I need to close the ticket tab then reopen it for it to show my workflow.

1 Like

Yes, exactly.

Thank you so much! I tried your suggestion and it did work when I created a new object with type “Select” but it still doesn’t work on object type “Tree Select”

I cannot reproduce what you’re talking about.
Ensure your Zammad version is current.

If you still experience the issue, please note that you’ve slected “saved conditions”. Saved conditions have to be applied to the ticket before they can work.

You may also want to have a look at the documentation:
https://admin-docs.zammad.org/en/latest/system/core-workflows.html

2 Likes

Thanks for your response!
We are running the latest version of Zammad and I did try “Selected Conditions” instead but it’s not working for object type Tree Select. I even tried it on a fresh installation of Zammad but no luck.

I am sorry, I still can’t reproduce.
You can try to update to the latest possible Zammad version and try again.

Please also note the following remarks on the documentation which may be the reason for your issues:
https://docs.zammad.org/en/latest/prerequisites/software.html#network-requirements