Docker-compose zammad uses all cpus and 60 gb ram

Infos:

  • Used Zammad version: 5.x
  • Used Zammad installation type: docker-compose (source, package, docker-compose, …)
  • Operating system: Ubuntu 18.04 lts on vm

Expected behavior:

  • Zammad not using 100% cpu on 60 gb ram for 10 concurrent users and a couple of email instances

Actual behavior:

Zammad using 100% cpu and 60 gb ram for 10 concurrent users and a couple of email instances

Also sometimes elasticsearch fails because it cannot allocate 31675383808 bytes (~30 gb) ram

This server is running nothing but docker, docker-compose and zammad

Docker allows you to set specific limits for specific containers if needed.
Also the elasticsearch container has elasticsearch specific environment options to limit the used memory.

What you’re looking for here is called heap-size in the ES universe.