Disable E-Mail when Login from a "new" device

Infos:

  • Used Zammad version: 4.0.x

Expected behavior:

  • Option to disable this notification.

Actual behavior:

  • With a new login from a “new machine” like in private Mode, an E-Mail is sent, that there was a new login.

Steps to reproduce the behavior:

  • Log into your account within a private window, watch your E-Mail Inbox for a new mail with the new Login.

The following documentation pages should help you:

Thanks for the fast answer.
So it is this configuration setting System Notifications — Zammad documentation in the User preferecens all checks from “Notify also via E-Mail” are removed.

In the systemnotifications is not described how to disable them. Is there some kind of magic value to disable them?

Is there any way to disable the Login notification?

Problem still exists…

Have a look at the admin documentation regarding user permissions again.
I’ve provided all required pointers to learn and adjust the configuration of your roles as needed.

Can you please guide me a little more?
Even in the admin account with full permissions all E-Mail notifications are unechecked and still I get an notification E-Mail every time I login, because I do this in a private windows.

Problem still persistent…

This is not a problem, it’s a design choice by the creators of Zammad to have this as a security feature.


Disable “device” permission for role “Agent” and they will not receive this notification. The documentation Marcel linked has this as the very first image on the page and since the e-mails are “New device detected” notifications it shouldn’t have been such a problem to find out on your own.

You can’t disable this for admins though. Maybe don’t open Zammad in a private window :wink:

You can.
device permission can be revoked or given to any role.