Default Formatting of email body on auto-reply trigger unusable

Infos:

  • Used Zammad version: 5.3.0-1671020558.31fad343.focal
  • Used Zammad installation type: package
  • Operating system: Ubuntu 20.04.5 LTS
  • Browser + version: Google Chrome 108.0.5359.125

Expected behavior:

  • I reconfigured the preset trigger for the initial auto-reply to let the customer know I received their request and wrote some new lines for the email body. Since there are no rich formatting options available in that body field, I would expect the text to be black and without any special effects.

Actual behavior:

  • But the text being generated by that trigger is displayed grey on every receiving email client and therefore unreadable.

I already tried to clear any formatting I could have accidentally copied over, so I ran the text through Word and cleared any formatting, I copied it from various text editors, but no change.

Here is a screenshot of one such generated email:

It’s especially had to read on a light mode mail client like Gmail.

You must have copied gray text from somewhere. Have you tried the keyboard shortcut for removing all formatting? You can see the list of available keyboard shortcuts by clicking on your Profile Icon in the bottom left of Zammad.

1 Like

Thanks for your input.
After using the respective keyboard shortcuts (Shift+Ctrl+Y or Ctrl+A & Shift+Ctrl+F) to remove the formatting, the text is now displayed properly.

However, why is this made unnecessarily complicated?
Why not have a WYSIWYG-style toolbar with formatting options for the body text fields, and, more importantly, as it is right in the name of WYSIWYG, show the actual formatting of the text which will be displayed to the end user?
What is the benefit of having it readable for the admin but the actual users, who have to read the text, get completely different formatting, which is not immediately obvious?

1 Like