Customer can view articles in the Knowledge Base with visibility internally

Infos:

  • Use Zammad version: 3.6.X

Expected behavior:

  • Customers cannot view articles in the knowledge base that have been configured with a visibility internal . The explanation says: Visible to editors and agents.

Actual behavior:

  • Customers see articles in the knowledge base with visibility internal .

Steps to reproduce the behavior:

  • Create articles in the knowledge base with visibility internal.
  • Open as customer the knowledge base.

Have I configured something wrong? What’s wrong?

Thank you for your answers

1 Like

If I’d had to guess I’d say the customer role has “knowledgebase.read” permissions which is a bad idea.

Is the knowledge base only intended for agents, but not for customers?

My idea was that customers could and should do their own research in the Knowledge Base.
However, now I have seen that linked tickets to the article in the knowledge base are visible for all customers.
Is that right?

Thank you for your answers

1 Like

I have the same problem and the same question.
In generel, can normal customers read the KnowledgeBase ?
Either I have a wrong configuration or i misunderstood the KB feature.

Hi all,

in our KB we have articles for agents and for clients.

image

with the visibility set to internal (agents only).

And for clients it looks like this:

image

When we want the client to access the article we send them the public link which can be accessed by clicking on the image icon (top right corner).

By default, our clients cannot access internal KB articles.

Best,
Martin

Thank you for this information! Then there is a problem with our Zammad configuration.

When I try to open the described button, I get a new browsertab with this:

Even with Agent and Administrator Roles I cannot view the KB entry with the directlink.

Maybe that explains why the customers can’t view the KB…

hallo @albzundy

you have to make sure that
a) the KB is enabled :slight_smile:
b) “visibility” = public for the article/s you want to share

HTH

Best,
Martin

Hello rsysadmin,

of course the KB is enabled :slight_smile:
As agent I can read and write articles in the knowledge base.
But not with the direct link!

And of course I set the visibility to public for some entries.

The default URL for the public knowledgebase page is /help.

Linked tickets are not visible to customers, unless they have knowledge_base.* permissions.
We believe (and consider) knowledgebase permissions as agent permissions not suitable for your customers.

Public articles are always visible for anons and customers.
We did update the documentation to relfect that better, sorry for the confusion. ( Agent Permissions — Zammad documentation
)

I found my problem:
The URL settings are not default but the webserver config wasn’t updates.
The default URL is example.com/help but in our system someone chaned it to /kb.

I wrote /help instead and now it works :slight_smile:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.