Customer and Agent have same email, responses are routed to wrong address

  • Used Zammad version: 2.5
  • Used Zammad installation source: built from package
  • Operating system: CentOS 7
  • Browser + version: Any

Hi everyone,

I’ve ran into problem that I don’t know how to solve.

Several of our users are combining two roles - Agent and Customer. If this user sends request to a queue and someone will respond, this user won’t receive the notification and response because response will be sent to a queue email for some reason.

I tried to change Settings-> Emails -> Sender based on Reply-To header which is apparently supposed to deal with cases like mine, but behaviour remains to be the same.

Detailed example:

User A:, an Agent and Customer (replies to tickets, sends new tickets)
User B:, an Agent (just replies to tickets)

User A sends ticket to email which is connected to corresponding support queue. Agents can see the ticket sent by User A. User B responds to ticket and for some reason email field To: appears to be automatically set to queue email User A obviously won’t receive email and won’t receive any information about ticket updates if this email is not changed manually into User A’s email address.

Expected behaviour is to see User A email in To: field automatically. This works perfectly for user that are just Customers, but doesn’t for users combining Customer and Agent roles.

I will appreciate any ideas.

zammad doesn’t like agents being customers at the same time.

Beside that I tested exactly what you’re trying to do some days ago.
When User B answers my E-Mail, I will get the reply to my E-Mail account (notifications to customers are set to off in my instance).

Could you provide headers of the E-Mail User A sends to the system?

@MrGeneration, thank you for the followup. The configuration we are discussing now is not something unheard of, a lot of organizations have similar situation when Agent can request something and become a Customer.

Just checked email headers, seems like nothing special there:

From: S ---------- <>
To: IT support <>
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: multipart/alternative; boundary="_----------=_15306123875237522"
X-Mailer: Webmail Interface - ajax-0d8ea36c
Date: Tue, 03 Jul 2018 18:06:27 +0800

This is a multi-part message in MIME format.

Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset="utf-8"


*S --------*

The Headers look totally fine, you’re right.

Just to make sure: You didn’t happen to assign the group “customer” to User A ?

Because: This would create a conflict.
In my setup I just sent a E-Mail again from the E-Mail registered to the system as agent. My User-Account has just agent assigned (no customer).

This should work - a user being agent anyway (because he need the rights) shouldn’t get the customer role as it won’t matter (except for special features you might just encounter).

@MrGeneration, yes, just doublechecked. Agent has agent role only. Zammad shows a message informing about conflict if I try to check both Agent and Customer role.

Zammad has following options related to the problem at Email -> Settings:

Sender based on Reply-To header
Set/overwrite sender/from of email based on reply-to header. Useful to set correct customer if email is received from a third party system on behalf of a customer.

Customer selection based on sender and receiver list
If the sender is an agent, set the first user in the recipient list as a customer.

The first one doesn’t work in my case since mail system is not setting Reply-To header for outgoing emails. The second one doesn’t really make sense to me, but I guess it is applicable to certain cases.

Thanks for the clearification.
That’s really odd.

My configuration looks as follows:

Hope it’s big enough.
But basically I have the first option enabled.

@MrGeneration, thank you for the screenshot.

Today I tried different combinations of Sender based on Reply-To header, Customer selection based on sender and receiver list and Sender Format (you have those set differently from default values). None of those combinations made it reply to a proper Sender. Every time I tried to Respond in Zammad I got Queue email as recipient of response. Weird.

I asked mail system to enable Reply-To header and hoped it will help, but no, it didn’t help.

As a temporary solution I am including my email into recipient list every time I am sending new request into queue. It’s not really convenient but at least I am receiving all notifications.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.