Custom icons in zammad

Infos:

  • Used Zammad version: Zammad versión 5.3.1-1672769502.c29df3bd.centos8
  • Used Zammad installation type: packahe centos
  • Operating system: centos8
  • Browser + version: chrome Versión 108.0.5359.125 (Build oficial) (64 bits)

Expected behavior:

This is a dumb question, but I can’t figure it out yet!

Let’s see if anyone has any ideas…

I wanted to customize the loading and bird icons zammad…

i did it as follows, rename /opt/zammad/public/assets/images/icons.svg_old

and I replaced it with the custom icons, but it didn’t work, all the icons remained white (img attached)

I went back to reset the icons file to default, but even so my zammad environment still shows all the icons in white!

I already reinstalled everything from scratch, using the same BD… and the problem persists

any idea of how to solve it, without losing the BD

because I see that the error config is from the BD…

and not from the zammad installation

I read this in the readme file in the images directory

Recreating the Zammad SVG Icon Store

$ yarn install
$npx gulp build
[14:08:17] Using gulpfile zammad/public/assets/images/gulpfile.js
[14:08:17] Starting 'build'...
[14:08:17] Finished 'build' after 7.48ms

but I am in CENTOS environment, can you guide me how to build from centos

Give this a try:

zammad run rake assets:precompile

I tried this option zammad run rake assets:precompile and this zammad run rails assets:precompile

but it gave me the following problems

warning " > linkify-html@3.0.5" has unmet peer dependency “linkifyjs@^3.0.0”.
warning “@graphql-codegen/cli > cosmiconfig-typescript-loader@4.1.1” has unmet peer dependency “@types/node@".
warning “@graphql-codegen/cli > cosmiconfig-typescript-loader@4.1.1” has unmet peer dependency “ts-node@>=10”.
warning “@graphql-codegen/cli > graphql-config > ts-node@10.9.1” has unmet peer dependency "@types/node@
”.
warning " > @testing-library/user-event@14.4.3" has unmet peer dependency “@testing-library/dom@>=7.21.4”.
warning " > @testing-library/vue@6.6.1" has unmet peer dependency “@vue/compiler-sfc@>= 3”.
warning " > vite-plugin-pwa@0.13.1" has unmet peer dependency “workbox-build@^6.5.4”.

which I solved by updating zammad, which fixed the icon problem

1 Like

Do you have node.js installed? It is required in order to run precompile:

https://docs.zammad.org/en/latest/prerequisites/software.html

Yes, I still consider the problem solved

since with the update it was repaired