CTI integration - how to use extra attribute from user?

Infos:

  • Used Zammad version: 5.3.1
  • Used Zammad installation type: package
  • Operating system: ubuntu 20.04
  • Browser + version: chrome 109.0.5414.75

Expected behavior:

  • cti integration searches for user attribute (self added to user object)

Actual behavior:

  • cti integration searches for user attribute telephone number and display correct user when a call arrives
  • cti integration searches for user attribute mobile number and display correct user when a call arrives
  • cti integration searches not for further user attributes

I had added an attribute “Kurzwahl” (trans. speed dial) to the user, because some clients are calling to us with ther internal speed dial number (3 digits). So cti can’t identify the correct caller.

Hi,

you can try using the following REST API route:

PUT /api/v1/object_manager_attributes/[ID of the object]
Ou can set the input type in the body.

I am not sure if this working with 3-digit numbers but it works great with regular phone numbers.

We have added “Direktdurchwahl” as an object. So additionally to Phone and Mobile we had a third object for a phone number. Also here our CTI integration did not find this number. But after changing the type to “input > tel” it worked fine.

Here is a screenshot of our settings:

Be careful as you can easily mess up things here. Ideally use a testing system first or create a backup/snapshot before atempting any changes.

Cheers,
Gijs

1 Like

Hi ecomsilio,

i had tried your approach, but with no success.
Maybe the length of the number is the key.
Can i ask how long your “Direktdurchwahlen” are in digits?

Hi @raik

In our case the phone number would be +49 30 577 017 10 and the “Direktdurchwahl” would be +49 30 577 017 125. So it still is a complete number, not only the last 3 digits.

We use this since some of our customers phone out with their “central number” but when I want to call them, I don’t want to got through their front desk but call them directly.

I have tried to enter our internal 2 digit extension and called my colleague but that is not working. So it might be the length of the digits or maybe the cti api does provide a different/complete number?!

Sorry that I can’t help here.

Cheers,
Gijs