CSRF token verification failed!

  • Used Zammad version: 3.4
  • Used Zammad installation source: (source, package, …)
  • Operating system: Plesk Docker CentOS7
  • Browser + version: Latest / Any

Expected behavior:

User logged in

Actual behavior:

CSRF token verification failed!

Steps to reproduce the behavior:

Navigate to dashboard URL and login


I tried searching for answers online but couldn’t find a solution that works for me, I’m using a docker in plesk with HTTPS let’s encrypt activated subdomain.

I found out that it happens when I restart the container in Plesk Docker, but when I reinstall the container everything is fine, until of course I restart the container, does anyone know what causes this and how I can fix it?

Thank you!

Have you checked here?

1 Like

Yes, but I didn’t find a solution there.

We’ve moved to a dedicated VPS instead of a docker, but I got a little confused following the installation guide > Zammad database configuration

This topic can be closed now, thank you kindly for your help, YosefAdPro, I appreciate it!

Problem also exists in VPS CentOS 7 RPM install.

I was wrong, it worked, but I placed it in the nginx.conf, instead of the configuration for Zammad.

proxy_set_header X-Forwarded-Proto https;

Thanks again for your help, I appreciate it!


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.