Create ticket from i-doit not working anymore

Hello guys,

I have a problem and can’t find a solution.

We use Zammad 4.1 and i-doit 1.17 PRO. I connected zammad to i-doit and can select an object by ticket creation. It works perfect. I can see the object in zammad in the sidebar and can click on the name of an object to open it in i-doit.

The problem: The other way is not working. Not tickets are shown in the table of the object:
image

If I click on “Ticket erstellen” (create ticket) the website open an new empty tab and on the source tab this error is shown:
image

My first idea was, that the i-doit installation has a problem. I installed a fresh new installation to test it. But the same result, it is not working.
Then i connected to your own Zammad demo. And now it works. So it must be a problem at my zammad installation. But what?
In the log files I cant find an idea. No relevant data.

If I try to get data by this code in the console of the i-doit server it works:

 curl -X POST -u "username:password" https://helpdesk.myorg.local/api/v1/tickets/search -d 'query=preferences.idoit.object_ids:391615' -d 'limit=10'

The result is the right data for tickets with ticket number.

Can anyone help me?
We use Zammad 4.1 on Ubuntu 20.04. The Zammad user has enough permissions to get the information.

The connection was fine for some month in my tests but now… I have no idea

THANKS! And sorry for my bad english

Beats me - that screen looks like i-doit UI.
So you may want to tail both logfiles (production log and access/error log from i-doit, however you check its logs) and try again.

There must be a clue shooting through your log files.
Especially if it’s working with demo instances it’s possibly a local networking issue, restriction rules or whatever.

We can help on application level, but this seems to be in front of the application.

I fixed the problem! My Problem was the self signed certificate.

My resolution:

  1. Copy the certificate and paste it under (Ubuntu 20.04) unter /usr/share/ca-certificates/extra (Create the folder if not exists)
  2. edit /etc/ca-certificates.conf and write down the path to your cert
  3. Type in putty: update-ca-certificates
1 Like