Core Workflow fields not appearing/disappearing

Infos:

  • Used Zammad version: 5.3.1-1674057058.5f657f26.focal
  • Used Zammad installation type: Package Install
  • Operating system: Ubuntu 20.04.5 TLS
  • Browser + version: Chrome 109.0.5414.75 (Official Build) (64-bit)

Expected behavior:

When I select ‘OneDrive/Drop Box Access’ as a Request (custom Object) fields should appear in accordance to what was set in the Core Workflow

Actual behavior:

Only the default values stay as specified in the Object permission. I switch the request to a different option (IT helpdesk) and all the objects for OneDrive/Drop Box access request show up for IT helpdesk (which they shouldnt)

Steps to reproduce the behavior:

  1. Create a list of objects that should only appear when Request is OneDrive/Drop Box access. The only object that is configured as Shown and Required is the Request object where the user selects the helpdesk option

  2. Create a workflow as shown

  3. As a user, create a new ticket. The default is set to IT Helpdesk, which shows up correctly. When I select Onedrive/Dropbox Access request, Location and PC Name should disappear and new fields should appear

As shown below:

Any help with this would be appreciated. To give a broad overview of what I’m trying to do accomplish is to allow the user to specify what type of ticket they need to forward the tickets to the appropriate agents. So far, the interaction between Object permissions (showing/requiring) and trying to use the Core Workflow rules has not been as intuitive as I would have thought. Some cases being fields are there, but as soon as I type anything into any field and click out of the field, the custom objects disappear if they are not checked to ‘Show’ in their object properties, and the workflow rule makes them show up.

Just an update, if I create a ticket with the values given to me under OneDrive/Drop Box Access (which are incorrect) I can go back into the ticket, click OneDrive/Drop Box Access and click update and everything works normally. It only does not remove the fields in the initial ticket creation

Other weird things that occur. If I set the Location object as not required in the Object properties, and I set Location set mandatory in the IT helpdesk Workflow, it initially shows as mandatory, but if I set Urgency, it becomes optional. I’m not sure if the object permission takes priority over workflow settings or not.

Trying to create a ticket with the OneDrive/dropbox request selected, does not update the fields correctly, but won’t let me create a ticket with random errors. If I edit a ticket created as IT helpdesk, and set it as OneDrive/Dropbox Request, all the fields are correct after update.

Initial ticket

Switched Request type and clicked Update

If you want Zammad to remove fields if a specific value is not set, you’ll need a core workflow rule that initially hides all fields before you check what to display.

You can also by default not display the object (that’s an object option you can use) and then just display what you need. That would spare you from the initial core workflow rule.

Object options: Object permissions — Zammad documentation

Hi,

Thanks for the response. I rebooted the server and selecting the request type is now populating the correct fields.