Consider accented characters in research

Hi,

Infos:

  • Used Zammad version: 4.1.0-1632223866.38f67335.buster amd64
  • Installation method (source, package, …): package
  • Operating system: Debian 10
  • Database + version: mariadb-server 10.3.29-0+deb10u1 amd64
  • Elasticsearch version: elasticsearch-oss 7.10.2 amd64
  • Browser + version: Safari, Firefox (lastest versions)

Expected behavior:

  • Accented characters are considered in research, for example looking for problem will return tickets containing problem, problèm, problém… words.

Actual behavior:

  • Accented characters are not considered in research, for example looking for problem will not return tickets containing problèm, problém… words.
    Which of course is a problem :slight_smile: Possible workaround is to look for probl?m, but it’s not really user-friendly.

Steps to reproduce the behavior:

  • Create a ticket containing problèm word. And then look for problem.
  • The other way also triggers the issue : create a ticket containing problem word. And then look for problèm.

Possible solution:

As per my findings, and if research is fully handled by Elasticsearch, asciifolding filter option in Elasticsearch could be the trick.

Many thanks :+1:

As per my findings, we can’t use elasticsearch.yml anymore to enforce asciifolding.
If true, the modification should then be done in Zammad directly.
Thank you again !

Can confirm Zammad does not allow to search for text containing accented characters by typing non-accented base character.

@MrGeneration I’d say this is a valid feature-borderline-bug. Do you mind if I reopen the github issue?

2 Likes

Please ask product owners not me.