Configure receiving notifications about closed tickets

Friends, tell me, please, maybe someone has already solved a similar problem?

  1. We need to make a backup copy of outgoing emails to the client.
  2. It is necessary for the manager to receive a notification when the ticket is closed.

I set up “system_bcc” and I set up a trigger to receive a notification when ticket closing.

Problem. the backup contains the messages " closing notifications"

A convenient mechanism is to use notifications, but there is no notification of closing.

If you can’t configure it, can you tell me where you can change it in the code ?

Infos:

  • Used Zammad version: 3.4
  • Used Zammad installation source: (source, package, …)
  • Operating system: Ubuntu 18
  • Browser + version: Chrome

Expected behavior:

configure receiving notifications about closed tickets.

Actual behavior:

receive notifications of all changes to the tickets.

Steps to reproduce the behavior:

I guess you’re talking about agent notifications: There’s no possibility to not sent a notification upon ticket update, but on closing only.

As I’m no developer, I can’t give you code examples. Sorry.

Having the same issue here.
Zammad 3.4.x installed from RPM and running on CentOS 8.

Email channel works flawlessly. Fetchmail does a great job.

We, Agents, can see when a fellow Agent updates the ticket but End-Users/Clients do not get any notification, regardless the state of the ticket.
Ideally they (Clients) should get ticket updates when the status changes and, of course, when it is closed.

Is such functionality implemented? if so, how can we enable it?

TIA

I have also enabled “notifications” under the Customer Role…

zammad-customer-notifications

…but still it has no effect on the Customer’s profile:

I was expecting to see something similar to this:

Also, I played around with the Triggers:

but nothing arrives to the Customer’s inbox once an Agent closes or updates a ticket…

Am I overseeing the obvious? Oo

Thanks

The former documentation wasn’t clear enough on this topic - we’ve fixed that (https://admin-docs.zammad.org/en/latest/manage/roles/user-preferences-permissions.html)

TL;DR: The customer is not supposed to have notification settings. These are for agents only.

(I’ll continue below)

The right way, like you thought later on, is to use triggers.

This has several benefits over the normal notification settings for agents:

  • You decide if, what and how your customer receives information on ticket creations or even updates
  • the mail from is always the mail address of the affected group, this way you don’t use the notification sender which allows using multiple different brands within one system for example

Personally I would also add the condition “action is updated” to above example of your trigger.
It will trigger on every update of the ticket as long as the state is “closed”.

Personally and maybe also from a support and customer happiness view, I prefer “personal” responses over automated ones. If you provide me a solution via mail or by phone (because somehow you have to solve my problem :wink: ) I’ll know the issue has been solved. But that’s taste. :slight_smile:

In order for triggers to actually send out mails, your group has to have a email address configured.
If it doesn’t, you can’t reply on tickets via mail and the trigger will not fire. There’s no fallback to the default notification sender.

A good hint of how a trigger can look like is the default trigger on ticket creation for customers too.
Maybe the docs can help you too:

I checked the groups. Even the default Users group does not have an email defined:

You do not even have the chance to assign an email address to the group during the group creation stage…

So, how would I add an email address to the group?

TIA and have a great weekend!

You have to add an email account before.
Choose your poison:

After that you can select the email address in question to start.
The group creation is indepentend of that step because you might want to create a group without mail address or already have an account configured.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.