Chat Unavailable


  • Used Zammad version: 3.3
  • Used Zammad installation source: package
  • Operating system: ubuntu 18.04
  • Browser + version: Version 80.0.3987.149 (Official Build) (64-bit)

Expected behavior:

Actual behavior:

  • Chat does not appear.

io debug || send chat_status_customer {session_id: null, url:…ew_nonce=07bcaeb5cd&_thumbnail_id=-1&preview=true”, chat_id: 1}

io debug || onMessage [{“event”:“chat_error”,“data”:{“state”:“chat_unavailable”}}]

debug || ws:onmessage {event: “chat_error”, data: {…}}

chat notice || {state: “chat_unavailable”}

Chat is enabled in settings, and I have activated the I am here to chat option as well.
My thought is this might be port based? Does the chat use a different port than 80 that I would need to forward? I didn’t see anything about that in the admin instructions.

If it matters I am running nginx for the web access.

Doesn’t seem like you have at least one agent being online, having the chat functionality activated on the frontend and also enabled the chat topic with ID1.

Ensure “Chat” is activated on the left greyish part of Zammad.
Click on “Chat” on the left (below overview) and then on “Settings” on the right site and see if the topic is active at all.

Good Morning. Thanks for replying.
I believe I enabled those settings correctly, unless I’ve made a dumb mistake on my behalf.


When replacing your host information with mine, it’s working without any issues.
Please note: I strongly advise you to use https for Zammad, not only for chatting, but especially for logging in and working on tickets. What you’re doing there is quite dangerous for the security of your data.

The following code works out of the box:

<script src=""></script>
<button class="open-zammad-chat">Chat with us</button>
<script src=""></script>
$(function() {
  new ZammadChat({
    background: '#161a1b',
    fontSize: '12px',
    chatId: 1,
    show: true,
    host: 'ws://',
    debug: true


Ensure your agent account is logged in, chat is activated (just like within your screenshots) and then try to open the chat. A reload of the page you’re testing with might be needed.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.