Change LDAP-Integration UID value

  • Used Zammad version: 3.1.x
  • Used Zammad installation source: package
  • Operating system: CentOS7
  • Browser + version: Firefox

Hey everyone,

I was wondering if there was a way to change this:
UID | objectguid

to this:
UID | samaccountname
in the LDAP-Integration settings.

I’ve been lookin for some kind of solution for some time now. I’ve tried to change it by editing the /zammad/lib/ldap/user.rb file a bit but it’s still using the objectGUID as UID and I don’t really know Ruby to get any further. Is there some kind of workaround for this?

Would you please describe your use case, and further more important, let us know what LDAP source you’re using?

It’s an active directory!

So it turns out that we are going to switch to a new domain soon, meaning that the ObjectGUIDs of all the users will change. And I’m guessing that, because of the changed ObjectGUID, new users will be created and all the tickets will be lost/inaccessible for the users.
So I’m hoping that I can modify the system to use the samaccountname instead of the GUID.

Is that possible? And if so, how?

I’ve set up the Zammad-System recently and removed our old Helpdesk-System, so there is not really a way back.

I’m not entirely sure if this is really what you’ll want to do and if it will fix your issue.
Anyway.

Warning: While this is no destructive work, it might cause issues when handling wrong. We suggest having a backup ready, just in case!

Dangerzone

The following actions are done within the rails console.

First of all you’ll need to retrieve the current UUID-Key:
Setting.get('ldap_config')['user_uid']

Now you’ll need to set the new attribute you want to use. Note that this might also affect your search filters.
Setting.set('ldap_config', Setting.get('ldap_config').merge('user_uid' => 'entryuuid'))

Replace user_id and entryuuid with the keys that fit to your system.

We don’t take any responsibility for issues that do appear with using the above commands.

Yeah it seems to be working so far. Thanks!
I will update this post after the transition, in case anyone else is in a similar situation.