Cant upgrade to 3.1 no space

Used Zammad version: 3.0
Installation method (source, package, …): package
Operating system: Linux
Database + version: Postgres 9.6

Hi, during upgrade i got:

dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/zammad_3.1.0-1562865639.aa61d8dd.jessie_amd64.deb (--unpack):
 »/opt/zammad/app/controllers/cti_controller.rb.dpkg-new« konnte nicht angelegt werden (während der Verarbeitung von »./opt/zammad/app/controllers/cti_controller.rb«): Auf dem Gerät ist kein Speicherplatz mehr verfügbar
dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet

but there is enough space:

root@witte-zammad:~# df -i

Dateisystem                 Inodes IBenutzt  IFrei IUse% Eingehängt auf
udev                        761566      367 761199    1% /dev
tmpfs                       764380      518 763862    1% /run
/dev/dm-0                   121920    11649 110271   10% /
/dev/dm-2                   121920    36404  85516   30% /usr
tmpfs                       764380        3 764377    1% /dev/shm
tmpfs                       764380        5 764375    1% /run/lock
tmpfs                       764380       15 764365    1% /sys/fs/cgroup
/dev/sda1                   121920      332 121588    1% /boot
/dev/mapper/vg--zammad-home  60928       25  60903    1% /home
/dev/mapper/vg--zammad-var  977280     6549 970731    1% /var
/dev/mapper/vg--zammad-tmp   60928       22  60906    1% /tmp
/dev/mapper/vg--zammad-opt  121920    94954  26966   78% /opt

root@witte-zammad:~# df -h

Dateisystem                 Größe Benutzt Verf. Verw% Eingehängt auf
udev                          10M       0   10M    0% /dev
tmpfs                        1,2G    8,6M  1,2G    1% /run
/dev/dm-0                    1,8G    452M  1,4G   26% /
/dev/dm-2                    1,8G    960M  848M   54% /usr
tmpfs                        3,0G    8,0K  3,0G    1% /dev/shm
tmpfs                        5,0M       0  5,0M    0% /run/lock
tmpfs                        3,0G       0  3,0G    0% /sys/fs/cgroup
/dev/sda1                    453M     62M  384M   14% /boot
/dev/mapper/vg--zammad-home  922M    1,3M  895M    1% /home
/dev/mapper/vg--zammad-var    15G    2,0G   13G   14% /var
/dev/mapper/vg--zammad-tmp   922M    1,4M  895M    1% /tmp
/dev/mapper/vg--zammad-opt   1,8G    775M  1,1G   43% /opt

had someone a idea what could be wrong?

I would suspect that this is the issue. dpkg will probably extract all files from the *.deb file as .dpkg-new and will only overwrite the old files as soon as all files have been extracted, so your volume needs to have enough space to contain two full Zammad installations. The current *.deb contains ~32000 files, and your volume only has enough space for ~30000 files:

martin ~ # dpkg-deb -c zammad_3.1.0-1562865639.aa61d8dd.stretch_amd64.deb|wc -l
31769
1 Like

that was exaktly the problem! thx!