Cant get Zammad to work when migrating from CentOS 7 to Ubuntu 20.04 LTS


On the CentOS machine i have Zammad 3.6.x. I followed the guide on how to make a backup. I then installed Zammad 3.6.x on the Ubuntu 20.04 LTS machine.

Transfered the backup files and used zammad_restore script to restore the backup.

I notice these errors while doing the backup: # Restoring Files# Ensuring correct file rights ...# Clearing Cache ...Tra -

Now zammad-web-1.service, zammad-websocket-1.service, zammad-worker-1.service all fails to start. Seems im missing som modules? It works fine on the CentOS7 machine.


I solved it with installing zammad as usual. Then i used the restore script which you can read about here Backup and Restore — Zammad documentation . after that i did a apt reinstall zammad, and now it works with the old database.

1 Like

Just a small side note (the documentation should reflect that but may confuse).
Above mentioned error technically is normal, because of a complete distribution switch.

Files on Ubuntu and CentOS systems to not match exactly.
Because you’re replacing source code files during restoration, this becomes an issues.

A forced reinstallation over that restored backup should fix the issue.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.