Can't edit things from admin area, not in tickets and not in user setting


  • Used Zammad version: same strange behavior, even on 5.4.1 and now on 6.0.0-1694414136.6c378be7.focal
  • Used Zammad installation type: package
  • Operating system: Ubuntu 20.04
  • Browser + version: Firefox 117 (x64) and Chrome 116

Expected behavior:

  • i want to use my Zammad self-hosted installation.

Actual behavior:

  • From one day to another (without makeing any changes to the server) zammad stopped taking any changes.

  • When i try to change owner and group of a Ticket i get the message “Das Speichern ist fehlgeschlagen” - translated to english “saving failed”.

  • When i try to change the language or something else in user-setting, it won’t save the changes.

  • When i try to change something from admin-panel (for example: change a user from admin to agent) it gets stuck in the edit dialog (all greyd out).

  • I can create a new user, new role, disable/enable smtp-polling.

  • If i try to change a user from admin to agent, i see this in the log:

I, [2023-09-12T12:12:28.870803#193413-114360]  INFO -- : Started POST "/api/v1/core_workflows/perform" for at 2023-09-12 12:12:28 +0000
I, [2023-09-12T12:12:28.883791#193413-114360]  INFO -- : Processing by CoreWorkflowsController#perform as JSON
I, [2023-09-12T12:12:28.884054#193413-114360]  INFO -- :   Parameters: {"event"=>"core_workflow", "request_id"=>"CoreWorkflow-892654", "params"=>{"note"=>"", "firstname"=>"Sc", "lastname"=>"Synergy", "email"=>"", "web"=>"", "phone"=>"", "mobile"=>"", "fax"=>"", "organization_id"=>"", "organization_ids"=>[], "organization_ids_completion"=>"", "department"=>"", "address"=>"", "password"=>"[FILTERED]", "password_confirm"=>"[FILTERED]", "vip"=>false, "role_ids"=>["1", "2"], "active"=>true, "group_ids"=>{"2"=>"full", "3"=>"full", "4"=>"full"}, "id"=>627}, "class_name"=>"User", "screen"=>"edit", "last_changed_attribute"=>"role_ids"}
I, [2023-09-12T12:12:28.898004#193413-114360]  INFO -- : not allowed to perform? this CoreWorkflowsController (Pundit::NotAuthorizedError)
app/controllers/application_controller/authorizes.rb:10:in `authorize!'
app/controllers/application_controller/authenticates.rb:140:in `authenticate_and_authorize!'
I, [2023-09-12T12:12:28.898612#193413-114360]  INFO -- : Not authorized (user)! (Exceptions::Forbidden)
app/models/user.rb:448:in `permissions!'
lib/user_context.rb:33:in `permissions!'
app/policies/controllers/application_controller_policy.rb:25:in `method_missing'
app/controllers/application_controller/authorizes.rb:10:in `authorize!'
app/controllers/application_controller/authenticates.rb:140:in `authenticate_and_authorize!'
I, [2023-09-12T12:12:28.899592#193413-114360]  INFO -- : Completed 403 Forbidden in 15ms (Views: 0.1ms | ActiveRecord: 5.6ms | Allocations: 4401)
  • If i try to set a owner and a group to a ticket, i see this in the log:
I, [2023-09-12T11:26:02.273394#795-413200]  INFO -- : Started POST "/api/v1/integration/smime" for at 2023-09-12 11:26:02 +0000
I, [2023-09-12T11:26:02.280868#795-413200]  INFO -- : Processing by Integration::SMIMEController#search as JSON
I, [2023-09-12T11:26:02.280982#795-413200]  INFO -- :   Parameters: {"ticket"=>{"group_id"=>"4", "owner_id"=>"636", "state_id"=>"1", "priority_id"=>"2", "geraetekategorien"=>"S"}, "article"=>{"body"=>"[FILTERED]", "type"=>"note", "internal"=>true, "form_id"=>"517921693", "shared_draft_id"=>"", "subtype"=>"", "in_reply_to"=>"", "to"=>"", "cc"=>"", "subject"=>""}}
I, [2023-09-12T11:26:02.297206#795-413200]  INFO -- : Completed 200 OK in 16ms (Views: 0.2ms | ActiveRecord: 5.3ms | Allocations: 4772)

Steps to reproduce the behavior:

  • I am sorry for this but i have no clue how to reproduce this behavior.
  • I fresh installation with imported backup has the same behavior.
  • I already tried to rebuild the searchindex, used db:migrate, updated from 5.4.1 to 6.0

It would be nice, if someone can help me out of here and make loved zammad system working again.
I use this installation since about 2 years.
Is there a simple way to restore the initial permissions to the database?
Could this be a solution?

But can you update the user in general or is it only some special situations not working?

Also, some looks for not working ticket upgrades would be interesting.

You can’t update the user in general even if you just assign groups to him or change the phone number.

Are there any issues logged in the browser console/in your production.log?

First, you should check, why the WebSocket connection is not working.

Thanks for the fast help we found the error.

Would be nice to share it with us. :slight_smile:

It simply was the WebSocket Connection which was Blocked by the Firewall. After reviewing the Firewall Options and changing them it worked again.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.