Can not connect to zammad from remote with server IP address

hello

I have changed localhost to my server IP address in /etc/nginx/sites-available/zammad.conf

this is the nginx config for zammad

upstream zammad-railsserver {
server 127.0.0.1:3000;
}

upstream zammad-websocket {
server 127.0.0.1:6042;
}

server {
listen 80;
listen [::]:80;

# replace 'localhost' with your fqdn if you want to use zammad from remote
#server_name localhost;
server_name 10.20.0.0;

but zammad is not starting with this IP, but with localhost it is

Can anyone help me, please?

You need to check the nginx logfile. Maybe you also have apache installed and it is already using port 80.

hi

apache is stopped, only nginx is running, but there are not logs in nginx logfile

You may wanna start to describe what you’re actually trying to do. This threads subject doesn’t add up to the text you wrote and may cause people on this board to send you the wrong way.

The template we’re suggestion for technical questions is this one:

### Infos:
* Used Zammad version: 
* Used Zammad installation type: (source, package, docker-compose, ...)
* Operating system: 
* Browser + version: 


### Expected behavior:

* 


### Actual behavior:

* 


### Steps to reproduce the behavior:

* 

thanks, I have solved this problem, zammad is starting with server ip address

and I was wondering, how to send reply to customer, is a customer can see a reply by admin

here, we can only add note(comments), can we reply to this message? and customer should receive reply

Can you tell us what the problem was and how you solved it?

Could help others who run into the same thing in the future.

As for replying to a ticket: You need to configure an email address to use in the group’s config.

Aside: Next time, could you open a new thread when you have a different topic, so that threads don’t mix different questions / topics? It could get messy otherwise. Thanks!

nothing else, I just reinstalled and corrected my etc/hosts file

for replying to a ticket: can anyone provide me an instruction or point me, please?

See the Admin Documentation here for the email setting: Group Settings — Zammad documentation

Absolutely not. Customers cannot see internal articles.
Have a full read on the role part of our documentation, smells like you have no idea what roles you are using and this potentially means data leaks.
https://admin-docs.zammad.org/en/latest/manage/roles/index.html

but I see “reply” button on the documentation of zammad

but on my zammad, I do not see this “reply” button

how can I activate this?

Have a look at the group configuration Martin mentioned.