Backup script don't delete old files

In configuration file I have set to store backup files 7 days (HOLD_DAYS=‘7’) but they not was deleted. Is it a bug?

Please provide a file listing of the backup directory with file permissions shown.

e.g. ls -la

Edit: I currently know of no installation where this doesn’t work.

@MrGeneration, I have tested one more weeks and see deletion of old archives work but strange. I have option HOLD_DAYS=‘7’ but archives stored 9.

Sorry I can’t see a reason why this shouldn’t work.
Our script uses best practise ways to remove x day old files:

Seems to be specific to your local environment.
I use similar commands like all the time on various situations and systems.

A reason might be that your filesystem is not writable 2 days (so causes the plus 2 days) or so.
Dunno, I’m afraid it’s out of scope of the application.

Clear, thank you! I will check with HOLD_DAYS=‘10’ as was be by default