Autocomplete user slow (20 sec to result)


  • Used Zammad version: 5.2.x
  • Used Zammad installation type: source
  • Operating system: Ubunto 20.04 (4 core 16 GB ram)
  • Browser + version: Chrome 106

Expected behavior:

Autocomplete fast!

Actual behavior:

when I use the autocomplete in the To or CC field of the new tickets or in response to the new tickets the autocomplete also takes over 20 seconds to show the results.
What can depend on the VM has 4 cores and 16 GB of RAM!

Steps to reproduce the behavior:

I found a problem and let’s say it’s a bit wrong with Zammad!
The problem arose from the Organizations, I had set the ordering for each user (I have over 40k of users entered in zammad), and for each autocomplete all 40k of IDs are returned to the json by ElasticSearch, which go to populate autocomplete, the data of the organizations with respective user data.
So we have for example: 40 user results, Organization name 1 (with 40k of all users who are part of the organization), etc …

I have not seen or found settings to disable this feature, although organizations are very comfortable.
The only solution was to put the Organization field for each user as “null” via API.

Is it possible to implement this function of excluding organizations from the autocomplete of the A or CC field?

Sorry I can’t follow your description.
You’re saying that you have an organization with over 40,000 users attached?

Apart from our documentation warning regarding those cases ( Organizations — Zammad documentation ) I don’t understand how that happened. Clearly Zammad doesn’t do it on it’s own so you most likely configured something for it to behave that way.

By default (without any automated assignments etc) there’s no organization assignment and thus no ID or reference to any organization for users - unless you configure it that way. For 40k entries this most likely is even caused by your browser because of the number of html elements it has to render. Of course that’s not the best performance you’ll have.

Maybe you can describe what you’re trying to achieve. Right now I’m really not able to follow well.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.